1 ################################################################################
5 ################################################################################
7 LIBATOMIC_OPS_VERSION
= libatomic_ops-7_4_4
8 LIBATOMIC_OPS_SITE
= $(call github
,ivmai
,libatomic_ops
,$(LIBATOMIC_OPS_VERSION
))
9 LIBATOMIC_OPS_AUTORECONF
= YES
11 # From doc/LICENSING.txt: "Our intent is to make it easy to use
12 # libatomic_ops, in both free and proprietary software. Hence most
13 # code that we expect to be linked into a client application is
14 # covered by an MIT-style license. A few library routines are covered
15 # by the GNU General Public License. These are put into a separate
16 # library, libatomic_ops_gpl.a."
17 LIBATOMIC_OPS_LICENSE
= MIT
(main library
) / GPLv2
+ (gpl extension
)
18 LIBATOMIC_OPS_LICENSE_FILES
= doc
/LICENSING.txt COPYING
20 LIBATOMIC_OPS_INSTALL_STAGING
= YES
22 ifeq ($(BR2_sparc_v8
)$(BR2_sparc_leon3
),y
)
23 LIBATOMIC_OPS_CONF_ENV
= CFLAGS
="$(TARGET_CFLAGS) -DAO_NO_SPARC_V9"
26 $(eval
$(autotools-package
))
27 $(eval
$(host-autotools-package
))