ruby: bump version to 2.4.1
[buildroot-gz.git] / package / mpg123 / mpg123.mk
blob27c46dcbc724df9d1661a57719e2254e71ee5093
1 ################################################################################
3 # mpg123
5 ################################################################################
7 MPG123_VERSION = 1.23.8
8 MPG123_SOURCE = mpg123-$(MPG123_VERSION).tar.bz2
9 MPG123_SITE = http://downloads.sourceforge.net/project/mpg123/mpg123/$(MPG123_VERSION)
10 MPG123_CONF_OPTS = --disable-lfs-alias
11 MPG123_INSTALL_STAGING = YES
12 MPG123_LICENSE = LGPLv2.1
13 MPG123_LICENSE_FILES = COPYING
14 MPG123_DEPENDENCIES = host-pkgconf
16 MPG123_CPU = $(if $(BR2_SOFT_FLOAT),generic_nofpu,generic_fpu)
18 ifeq ($(BR2_aarch64),y)
19 MPG123_CPU = aarch64
20 endif
22 ifeq ($(BR2_arm),y)
23 ifeq ($(or $(BR2_ARM_CPU_HAS_NEON),$(BR2_ARM_CPU_HAS_VFPV2)),y)
24 MPG123_CPU = arm_fpu
25 else
26 MPG123_CPU = arm_nofpu
27 endif
28 endif
30 ifeq ($(BR2_i386),y)
31 MPG123_CPU = x86
32 endif
34 ifeq ($(BR2_powerpc),y)
35 ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
36 MPG123_CPU = altivec
37 endif
38 ifeq ($(BR2_SOFT_FLOAT),y)
39 MPG123_CPU = ppc_nofpu
40 endif
41 endif # powerpc
43 ifeq ($(BR2_x86_64),y)
44 MPG123_CPU = x86-64
45 endif
47 MPG123_CONF_OPTS += --with-cpu=$(MPG123_CPU)
49 MPG123_AUDIO = dummy oss
51 ifeq ($(BR2_PACKAGE_PORTAUDIO),y)
52 MPG123_AUDIO += portaudio
53 MPG123_CONF_OPTS += --with-default-audio=portaudio
54 MPG123_DEPENDENCIES += portaudio
55 # configure script does NOT use pkg-config to figure out how to link
56 # with portaudio, breaking static linking as portaudio uses pthreads
57 MPG123_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs portaudio-2.0`"
58 endif
60 ifeq ($(BR2_PACKAGE_SDL),y)
61 MPG123_AUDIO += sdl
62 MPG123_CONF_OPTS += --with-default-audio=sdl
63 MPG123_DEPENDENCIES += sdl
64 endif
66 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
67 MPG123_AUDIO += alsa
68 MPG123_CONF_OPTS += --with-default-audio=alsa
69 MPG123_DEPENDENCIES += alsa-lib
70 # configure script does NOT use pkg-config to figure out how to link
71 # with alsa, breaking static linking as alsa uses pthreads
72 MPG123_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs alsa`"
73 endif
75 MPG123_CONF_OPTS += --with-audio=$(subst $(space),$(comma),$(MPG123_AUDIO))
77 ifeq ($(BR2_PACKAGE_LIBTOOL),y)
78 MPG123_DEPENDENCIES += libtool
79 # .la files gets stripped , so directly load .so files rather than .la
80 MPG123_CONF_OPTS += --with-modules --with-module-suffix=.so
81 endif
83 $(eval $(autotools-package))