1 ################################################################################
5 ################################################################################
7 # When bumping this package, make sure to also verify if the
8 # python-protobuf package still works, as they share the same
9 # version/site variables.
10 PROTOBUF_VERSION
= v3.0
.0
11 PROTOBUF_SITE
= $(call github
,google
,protobuf
,$(PROTOBUF_VERSION
))
12 PROTOBUF_LICENSE
= BSD-3c
13 PROTOBUF_LICENSE_FILES
= LICENSE
15 PROTOBUF_AUTORECONF
= YES
17 # N.B. Need to use host protoc during cross compilation.
18 PROTOBUF_DEPENDENCIES
= host-protobuf
19 PROTOBUF_CONF_OPTS
= --with-protoc
=$(HOST_DIR
)/usr
/bin
/protoc
21 PROTOBUF_INSTALL_STAGING
= YES
23 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
24 PROTOBUF_DEPENDENCIES
+= zlib
27 $(eval
$(autotools-package
))
28 $(eval
$(host-autotools-package
))