ruby: bump version to 2.4.1
[buildroot-gz.git] / package / protobuf / protobuf.mk
blobdabbfb7a4ac05a1d72335dc17fa755508fb41e29
1 ################################################################################
3 # protobuf
5 ################################################################################
7 # When bumping this package, make sure to also verify if the
8 # python-protobuf package still works, as they share the same
9 # version/site variables.
10 PROTOBUF_VERSION = v3.0.0
11 PROTOBUF_SITE = $(call github,google,protobuf,$(PROTOBUF_VERSION))
12 PROTOBUF_LICENSE = BSD-3c
13 PROTOBUF_LICENSE_FILES = LICENSE
14 # no configure script
15 PROTOBUF_AUTORECONF = YES
17 # N.B. Need to use host protoc during cross compilation.
18 PROTOBUF_DEPENDENCIES = host-protobuf
19 PROTOBUF_CONF_OPTS = --with-protoc=$(HOST_DIR)/usr/bin/protoc
21 PROTOBUF_INSTALL_STAGING = YES
23 ifeq ($(BR2_PACKAGE_ZLIB),y)
24 PROTOBUF_DEPENDENCIES += zlib
25 endif
27 $(eval $(autotools-package))
28 $(eval $(host-autotools-package))