ruby: bump version to 2.4.1
[buildroot-gz.git] / package / sdl / sdl.mk
blob38b4b977525f122dbf2df3dce55902accfb2afd6
1 ################################################################################
3 # sdl
5 ################################################################################
7 SDL_VERSION = 1.2.15
8 SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
9 SDL_SITE = http://www.libsdl.org/release
10 SDL_LICENSE = LGPLv2.1+
11 SDL_LICENSE_FILES = COPYING
12 SDL_INSTALL_STAGING = YES
14 # we're patching configure.in, but package cannot autoreconf with our version of
15 # autotools, so we have to do it manually instead of setting SDL_AUTORECONF = YES
16 define SDL_RUN_AUTOGEN
17 cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
18 endef
20 SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
21 HOST_SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
23 SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
24 HOST_SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
26 ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
27 SDL_CONF_OPTS += --enable-video-fbcon=yes
28 else
29 SDL_CONF_OPTS += --enable-video-fbcon=no
30 endif
32 ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
33 SDL_DEPENDENCIES += directfb
34 SDL_CONF_OPTS += --enable-video-directfb=yes
35 SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
36 else
37 SDL_CONF_OPTS += --enable-video-directfb=no
38 endif
40 ifeq ($(BR2_PACKAGE_SDL_QTOPIA),y)
41 SDL_CONF_OPTS += --enable-video-qtopia=yes
42 SDL_DEPENDENCIES += qt
43 else
44 SDL_CONF_OPTS += --enable-video-qtopia=no
45 endif
47 ifeq ($(BR2_PACKAGE_SDL_X11),y)
48 SDL_CONF_OPTS += --enable-video-x11=yes
49 SDL_DEPENDENCIES += \
50 xlib_libX11 xlib_libXext \
51 $(if $(BR2_PACKAGE_XLIB_LIBXRENDER), xlib_libXrender) \
52 $(if $(BR2_PACKAGE_XLIB_LIBXRANDR), xlib_libXrandr)
53 else
54 SDL_CONF_OPTS += --enable-video-x11=no
55 endif
57 ifneq ($(BR2_USE_MMU),y)
58 SDL_CONF_OPTS += --enable-dga=no
59 endif
61 # overwrite autodection (prevents confusion with host libpth version)
62 ifeq ($(BR2_PACKAGE_LIBPTHSEM_COMPAT),y)
63 SDL_CONF_OPTS += --enable-pth
64 SDL_CONF_ENV += ac_cv_path_PTH_CONFIG=$(STAGING_DIR)/usr/bin/pth-config
65 SDL_DEPENDENCIES += libpthsem
66 else
67 SDL_CONF_OPTS += --disable-pth
68 endif
70 ifeq ($(BR2_PACKAGE_TSLIB),y)
71 SDL_DEPENDENCIES += tslib
72 endif
74 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
75 SDL_DEPENDENCIES += alsa-lib
76 endif
78 ifeq ($(BR2_PACKAGE_MESA3D),y)
79 SDL_DEPENDENCIES += mesa3d
80 endif
82 SDL_CONF_OPTS += \
83 --disable-rpath \
84 --enable-pulseaudio=no \
85 --disable-arts \
86 --disable-esd \
87 --disable-nasm \
88 --disable-video-ps3
90 HOST_SDL_CONF_OPTS += \
91 --enable-pulseaudio=no \
92 --enable-video-x11=no \
93 --disable-arts \
94 --disable-esd \
95 --disable-nasm \
96 --disable-video-ps3
98 SDL_CONFIG_SCRIPTS = sdl-config
100 $(eval $(autotools-package))
101 $(eval $(host-autotools-package))