1 ################################################################################
5 ################################################################################
8 SDL_SOURCE
= SDL-
$(SDL_VERSION
).
tar.gz
9 SDL_SITE
= http
://www.libsdl.org
/release
10 SDL_LICENSE
= LGPLv2.1
+
11 SDL_LICENSE_FILES
= COPYING
12 SDL_INSTALL_STAGING
= YES
14 # we're patching configure.in, but package cannot autoreconf with our version of
15 # autotools, so we have to do it manually instead of setting SDL_AUTORECONF = YES
16 define SDL_RUN_AUTOGEN
17 cd
$(@D
) && PATH
=$(BR_PATH
) .
/autogen.sh
20 SDL_PRE_CONFIGURE_HOOKS
+= SDL_RUN_AUTOGEN
21 HOST_SDL_PRE_CONFIGURE_HOOKS
+= SDL_RUN_AUTOGEN
23 SDL_DEPENDENCIES
+= host-automake host-autoconf host-libtool
24 HOST_SDL_DEPENDENCIES
+= host-automake host-autoconf host-libtool
26 ifeq ($(BR2_PACKAGE_SDL_FBCON
),y
)
27 SDL_CONF_OPTS
+= --enable-video-fbcon
=yes
29 SDL_CONF_OPTS
+= --enable-video-fbcon
=no
32 ifeq ($(BR2_PACKAGE_SDL_DIRECTFB
),y
)
33 SDL_DEPENDENCIES
+= directfb
34 SDL_CONF_OPTS
+= --enable-video-directfb
=yes
35 SDL_CONF_ENV
= ac_cv_path_DIRECTFBCONFIG
=$(STAGING_DIR
)/usr
/bin
/directfb-config
37 SDL_CONF_OPTS
+= --enable-video-directfb
=no
40 ifeq ($(BR2_PACKAGE_SDL_QTOPIA
),y
)
41 SDL_CONF_OPTS
+= --enable-video-qtopia
=yes
42 SDL_DEPENDENCIES
+= qt
44 SDL_CONF_OPTS
+= --enable-video-qtopia
=no
47 ifeq ($(BR2_PACKAGE_SDL_X11
),y
)
48 SDL_CONF_OPTS
+= --enable-video-x11
=yes
50 xlib_libX11 xlib_libXext \
51 $(if
$(BR2_PACKAGE_XLIB_LIBXRENDER
), xlib_libXrender
) \
52 $(if
$(BR2_PACKAGE_XLIB_LIBXRANDR
), xlib_libXrandr
)
54 SDL_CONF_OPTS
+= --enable-video-x11
=no
57 ifneq ($(BR2_USE_MMU
),y
)
58 SDL_CONF_OPTS
+= --enable-dga
=no
61 # overwrite autodection (prevents confusion with host libpth version)
62 ifeq ($(BR2_PACKAGE_LIBPTHSEM_COMPAT
),y
)
63 SDL_CONF_OPTS
+= --enable-pth
64 SDL_CONF_ENV
+= ac_cv_path_PTH_CONFIG
=$(STAGING_DIR
)/usr
/bin
/pth-config
65 SDL_DEPENDENCIES
+= libpthsem
67 SDL_CONF_OPTS
+= --disable-pth
70 ifeq ($(BR2_PACKAGE_TSLIB
),y
)
71 SDL_DEPENDENCIES
+= tslib
74 ifeq ($(BR2_PACKAGE_ALSA_LIB
),y
)
75 SDL_DEPENDENCIES
+= alsa-lib
78 ifeq ($(BR2_PACKAGE_MESA3D
),y
)
79 SDL_DEPENDENCIES
+= mesa3d
84 --enable-pulseaudio
=no \
90 HOST_SDL_CONF_OPTS
+= \
91 --enable-pulseaudio
=no \
92 --enable-video-x11
=no \
98 SDL_CONFIG_SCRIPTS
= sdl-config
100 $(eval
$(autotools-package
))
101 $(eval
$(host-autotools-package
))