openocd: avoid documentation rebuild to fix build issues
[buildroot-gz.git] / package / linux-tools / linux-tool-gpio.mk
blobba75ab4c3fabcaa2d882c5ef534d07a3a68702b5
1 ################################################################################
3 # gpio
5 ################################################################################
7 LINUX_TOOLS += gpio
9 GPIO_MAKE_OPTS = $(LINUX_MAKE_FLAGS)
11 define GPIO_BUILD_CMDS
12 $(Q)if ! grep install $(LINUX_DIR)/tools/gpio/Makefile >/dev/null 2>&1 ; then \
13 echo "Your kernel version is too old and does not have the gpio tools." ; \
14 echo "At least kernel 4.8 must be used." ; \
15 exit 1 ; \
18 $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
19 $(GPIO_MAKE_OPTS) \
20 gpio
21 endef
23 define GPIO_INSTALL_TARGET_CMDS
24 $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
25 $(GPIO_MAKE_OPTS) \
26 DESTDIR=$(TARGET_DIR) \
27 gpio_install
28 endef