1 ################################################################################
5 ################################################################################
8 UPX_SITE
= http
://upx.sourceforge.net
/download
9 UPX_SOURCE
= upx-
$(UPX_VERSION
)-src.
tar.bz2
11 UPX_LICENSE_FILES
= COPYING
13 HOST_UPX_DEPENDENCIES
= host-ucl host-zlib
15 # We need to specify all, otherwise the default target only prints a message
16 # stating to "please choose a target for 'make'"... :-(
17 define HOST_UPX_BUILD_CMDS
18 $(HOST_MAKE_ENV
) $(MAKE
) CPPFLAGS
="$(HOST_CPPFLAGS)" \
19 LDFLAGS
="$(HOST_LDFLAGS)" UPX_UCLDIR
=$(HOST_DIR
)/usr \
24 # UPX has no install procedure, so install it manually.
25 define HOST_UPX_INSTALL_CMDS
26 $(INSTALL
) -D
-m
0755 $(@D
)/src
/upx.out
$(HOST_DIR
)/usr
/bin
/upx
29 $(eval
$(host-generic-package
))