openocd: avoid documentation rebuild to fix build issues
[buildroot-gz.git] / package / wayland / wayland.mk
bloba86239437c4b274009afc9090c0201643badd62e
1 ################################################################################
3 # wayland
5 ################################################################################
7 WAYLAND_VERSION = 1.12.0
8 WAYLAND_SITE = http://wayland.freedesktop.org/releases
9 WAYLAND_SOURCE = wayland-$(WAYLAND_VERSION).tar.xz
10 WAYLAND_LICENSE = MIT
11 WAYLAND_LICENSE_FILES = COPYING
12 WAYLAND_INSTALL_STAGING = YES
13 WAYLAND_DEPENDENCIES = host-pkgconf host-wayland expat libffi libxml2
14 HOST_WAYLAND_DEPENDENCIES = host-pkgconf host-expat host-libffi host-libxml2
16 # wayland-scanner is only needed for building, not on the target
17 WAYLAND_CONF_OPTS = --disable-scanner --with-host-scanner
19 # Remove the DTD from the target, it's not needed at runtime
20 define WAYLAND_TARGET_CLEANUP
21 rm -rf $(TARGET_DIR)/usr/share/wayland
22 endef
23 WAYLAND_POST_INSTALL_TARGET_HOOKS += WAYLAND_TARGET_CLEANUP
25 $(eval $(autotools-package))
26 $(eval $(host-autotools-package))