python-pyasn: bump to version 1.6.0b1
[buildroot-gz.git] / package / dvdauthor / dvdauthor.mk
blobe982a40e40b7cf35e4ba9a2603f009c32e6df4f9
1 ################################################################################
3 # dvdauthor
5 ################################################################################
7 DVDAUTHOR_VERSION = 0.7.1
8 DVDAUTHOR_SITE = http://sourceforge.net/projects/dvdauthor/files/dvdauthor/$(DVDAUTHOR_VERSION)
9 DVDAUTHOR_DEPENDENCIES = host-pkgconf libxml2 freetype libpng
10 DVDAUTHOR_LICENSE = GPLv2+
11 DVDAUTHOR_LICENSE_FILES = COPYING
12 DVDAUTHOR_CONF_ENV = \
13 ac_cv_prog_FREETYPECONFIG=$(STAGING_DIR)/usr/bin/freetype-config \
14 ac_cv_path_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config \
15 ac_cv_prog_GMAGICKCONFIG=
17 # configure.ac patched by 0001-configure.ac-fix-static-build.patch
18 DVDAUTHOR_AUTORECONF = YES
19 # add host-gettext for AM_ICONV macro
20 DVDAUTHOR_DEPENDENCIES += host-gettext
22 ifeq ($(BR2_PACKAGE_IMAGEMAGICK),y)
23 DVDAUTHOR_DEPENDENCIES += imagemagick
24 DVDAUTHOR_CONF_ENV += \
25 ac_cv_prog_MAGICKCONFIG=$(STAGING_DIR)/usr/bin/Magick-config
26 else
27 DVDAUTHOR_CONF_ENV += \
28 ac_cv_prog_MAGICKCONFIG=
29 endif
31 # Automatically detected by dvdauthor configure script, no way to
32 # disable.
33 ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
34 DVDAUTHOR_DEPENDENCIES += fontconfig
35 endif
37 ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
38 DVDAUTHOR_DEPENDENCIES += libfribidi
39 endif
41 ifeq ($(BR2_PACKAGE_DVDAUTHOR_DVDUNAUTHOR),y)
42 DVDAUTHOR_DEPENDENCIES += libdvdread
43 # dvdauthor configure does not use pkg-config to detect libdvdread
44 ifeq ($(BR2_PACKAGE_LIBDVDCSS)$(BR2_STATIC_LIBS),yy)
45 DVDAUTHOR_CONF_ENV += LIBS="-ldvdcss"
46 endif
47 DVDAUTHOR_CONF_OPTS += --enable-dvdunauthor
48 else
49 DVDAUTHOR_CONF_OPTS += --disable-dvdunauthor
50 endif
52 $(eval $(autotools-package))