board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / iptables / iptables.mk
blob90fab345bed859f9dbc7c6c96261cae94cec8085
1 ################################################################################
3 # iptables
5 ################################################################################
7 IPTABLES_VERSION = 1.6.1
8 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
9 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
10 IPTABLES_INSTALL_STAGING = YES
11 IPTABLES_DEPENDENCIES = host-pkgconf \
12 $(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)
13 IPTABLES_LICENSE = GPLv2
14 IPTABLES_LICENSE_FILES = COPYING
15 # Building static causes ugly warnings on some plugins
16 IPTABLES_CONF_OPTS = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr \
17 $(if $(BR2_STATIC_LIBS),,--disable-static)
19 # For connlabel match
20 ifeq ($(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),y)
21 IPTABLES_DEPENDENCIES += libnetfilter_conntrack
22 endif
24 # For nfnl_osf
25 ifeq ($(BR2_PACKAGE_LIBNFNETLINK),y)
26 IPTABLES_DEPENDENCIES += libnfnetlink
27 endif
29 # For iptables-compat tools
30 ifeq ($(BR2_PACKAGE_IPTABLES_NFTABLES),y)
31 IPTABLES_CONF_OPTS += --enable-nftables
32 IPTABLES_DEPENDENCIES += host-bison host-flex libmnl libnftnl
33 else
34 IPTABLES_CONF_OPTS += --disable-nftables
35 endif
37 # bpf compiler support and nfsynproxy tool
38 ifeq ($(BR2_PACKAGE_IPTABLES_BPF_NFSYNPROXY),y)
39 # libpcap is tricky for static-only builds and needs help
40 ifeq ($(BR2_STATIC_LIBS),y)
41 IPTABLES_LIBS_FOR_STATIC_LINK += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
42 IPTABLES_CONF_OPTS += LIBS="$(IPTABLES_LIBS_FOR_STATIC_LINK)"
43 endif
44 IPTABLES_CONF_OPTS += --enable-bpf-compiler --enable-nfsynproxy
45 IPTABLES_DEPENDENCIES += libpcap
46 else
47 IPTABLES_CONF_OPTS += --disable-bpf-compiler --disable-nfsynproxy
48 endif
50 $(eval $(autotools-package))