1 ################################################################################
5 ################################################################################
8 PV_SOURCE
= pv-
$(PV_VERSION
).
tar.bz2
9 PV_SITE
= http
://www.ivarch.com
/programs
/sources
10 PV_LICENSE
= Artistic-2.0
11 PV_LICENSE_FILES
= doc
/COPYING
13 # pv configure script is somewhat stupid: if it cannot find the host
14 # gettext tool msgfmt, it concludes that gettext is not available, and
15 # provides its own minimal version. Unfortunately, this minimal
16 # version conflicts with the available target gettext. We fix this by
17 # ensuring that host-gettext is built if gettext support is enabled;
18 PV_DEPENDENCIES
= $(if
$(BR2_NEEDS_GETTEXT_IF_LOCALE
),gettext host-gettext
)
20 # --relax linker option is enabled by default on sparc/sparc64
21 # architectures, and it can't be used together with -r option, so
23 ifeq ($(BR2_sparc
)$(BR2_sparc64
),y
)
24 PV_LDFLAGS
= "-Wl,--no-relax"
27 # While 'pv' uses autoconf, it does not use automake for its
28 # makefiles. It uses $(LD) $(LDFLAGS) to achieve partial linking, but
29 # using 'ld' directly doesn't work well with some toolchain
30 # configuration, as the ld default emulation may not necessarily be
31 # the correct one. By passing the below values for LD and LDFLAGS, we
32 # ensure that 'gcc' is used to do these partial linking steps.
35 LDFLAGS
="-Wl,-r -nostdlib $(PV_LDFLAGS)"
37 $(eval
$(autotools-package
))