board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / sconeserver / sconeserver.mk
blob793ca6fb261ff1fd484ee8a6c9ca1ba7ecdf1391
1 ################################################################################
3 # sconeserver
5 ################################################################################
7 SCONESERVER_VERSION = d659468cd164e6a6cc12932cc6780566b04f8328
8 SCONESERVER_SITE = $(call github,sconemad,sconeserver,$(SCONESERVER_VERSION))
9 SCONESERVER_LICENSE = GPLv2+
10 SCONESERVER_LICENSE_FILES = COPYING
11 # fetching from Git, we need to generate the configure script
12 SCONESERVER_AUTORECONF = YES
13 SCONESERVER_DEPENDENCIES = host-pkgconf pcre
14 # disable markdown module because its git submodule cmark
15 # https://github.com/sconemad/sconeserver/tree/master/markdown
16 # has no cross-compile support provided by the sconeserver build system
17 SCONESERVER_CONF_OPTS += --with-ip --with-local --with-ip6 --without-markdown
19 # Sconeserver configure script fails to find the libxml2 headers.
20 ifeq ($(BR2_PACKAGE_LIBXML2),y)
21 SCONESERVER_CONF_OPTS += \
22 --with-xml2-config="$(STAGING_DIR)/usr/bin/xml2-config"
23 endif
25 ifeq ($(BR2_PACKAGE_OPENSSL),y)
26 SCONESERVER_DEPENDENCIES += openssl
27 SCONESERVER_CONF_OPTS += --with-ssl
28 ifeq ($(BR2_STATIC_LIBS),y)
29 SCONESERVER_CONF_ENV += SSL_LIBADD=-lz
30 endif
31 else
32 SCONESERVER_CONF_OPTS += --without-ssl
33 endif
35 ifeq ($(BR2_PACKAGE_SCONESERVER_EXAMPLES),y)
36 SCONESERVER_CONF_OPTS += --with-examples
37 else
38 SCONESERVER_CONF_OPTS += --without-examples
39 endif
41 ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE),y)
42 SCONESERVER_DEPENDENCIES += libxml2
43 SCONESERVER_CONF_OPTS += --with-sconesite
44 else
45 SCONESERVER_CONF_OPTS += --without-sconesite
46 endif
48 ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
49 SCONESERVER_DEPENDENCIES += imagemagick
50 SCONESERVER_CONF_OPTS += \
51 --with-sconesite-image \
52 --with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
53 else
54 SCONESERVER_CONF_OPTS += --without-sconesite-image --with-Magick++-config=no
55 endif
57 ifeq ($(BR2_PACKAGE_SCONESERVER_MYSQL),y)
58 SCONESERVER_DEPENDENCIES += mysql
59 SCONESERVER_CONF_OPTS += \
60 --with-mysql \
61 --with-mysql_config="$(STAGING_DIR)/usr/bin/mysql_config" \
62 LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/mysql"
63 else
64 SCONESERVER_CONF_OPTS += --without-mysql
65 endif
67 ifeq ($(BR2_PACKAGE_SCONESERVER_BLUETOOTH),y)
68 SCONESERVER_DEPENDENCIES += bluez_utils
69 SCONESERVER_CONF_OPTS += --with-bluetooth
70 else
71 SCONESERVER_CONF_OPTS += --without-bluetooth
72 endif
74 ifeq ($(BR2_PACKAGE_SCONESERVER_RSS),y)
75 SCONESERVER_DEPENDENCIES += libxml2
76 SCONESERVER_CONF_OPTS += --with-rss
77 else
78 SCONESERVER_CONF_OPTS += --without-rss
79 endif
81 ifeq ($(BR2_PACKAGE_SCONESERVER_LOCATION),y)
82 SCONESERVER_DEPENDENCIES += gpsd
83 SCONESERVER_CONF_OPTS += --with-location
84 else
85 SCONESERVER_CONF_OPTS += --without-location
86 endif
88 ifeq ($(BR2_PACKAGE_SCONESERVER_LETTUCE),y)
89 SCONESERVER_CONF_OPTS += --with-lettuce
90 else
91 SCONESERVER_CONF_OPTS += --without-lettuce
92 endif
94 ifeq ($(BR2_PACKAGE_SCONESERVER_MATHS),y)
95 SCONESERVER_DEPENDENCIES += mpfr
96 SCONESERVER_CONF_OPTS += --with-maths
97 else
98 SCONESERVER_CONF_OPTS += --without-maths
99 endif
101 ifeq ($(BR2_PACKAGE_SCONESERVER_TESTBUILDER),y)
102 SCONESERVER_CONF_OPTS += --with-testbuilder
103 else
104 SCONESERVER_CONF_OPTS += --without-testbuilder
105 endif
107 ifeq ($(BR2_PACKAGE_SCONESERVER_UI),y)
108 SCONESERVER_DEPENDENCIES += xlib_libX11
109 SCONESERVER_CONF_OPTS += --with-ui
110 else
111 SCONESERVER_CONF_OPTS += --without-ui
112 endif
114 $(eval $(autotools-package))