1 ################################################################################
5 ################################################################################
8 WINE_SOURCE
= wine-
$(WINE_VERSION
).
tar.bz2
9 WINE_SITE
= https
://dl.winehq.org
/wine
/source
/1.8
10 WINE_LICENSE
= LGPLv2.1
+
11 WINE_LICENSE_FILES
= COPYING.LIB LICENSE
12 WINE_DEPENDENCIES
= host-bison host-flex host-wine
14 # Wine needs its own directory structure and tools for cross compiling
16 --with-wine-tools
=..
/host-wine-
$(WINE_VERSION
) \
29 # Wine uses a wrapper around gcc, and uses the value of --host to
30 # construct the filename of the gcc to call. But for external
31 # toolchains, the GNU_TARGET_NAME tuple that we construct from our
32 # internal variables may differ from the actual gcc prefix for the
33 # external toolchains. So, we have to override whatever the gcc
34 # wrapper believes what the real gcc is named, and force the tuple of
35 # the external toolchain, not the one we compute in GNU_TARGET_NAME.
36 ifeq ($(BR2_TOOLCHAIN_EXTERNAL
),y
)
37 WINE_CONF_OPTS
+= TARGETFLAGS
="-b $(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))"
40 ifeq ($(BR2_PACKAGE_ALSA_LIB
)$(BR2_PACKAGE_ALSA_LIB_SEQ
)$(BR2_PACKAGE_ALSA_LIB_RAWMIDI
),yyy
)
41 WINE_CONF_OPTS
+= --with-alsa
42 WINE_DEPENDENCIES
+= alsa-lib
44 WINE_CONF_OPTS
+= --without-alsa
47 ifeq ($(BR2_PACKAGE_CUPS
),y
)
48 WINE_CONF_OPTS
+= --with-cups
49 WINE_DEPENDENCIES
+= cups
50 WINE_CONF_ENV
+= CUPS_CONFIG
=$(STAGING_DIR
)/usr
/bin
/cups-config
52 WINE_CONF_OPTS
+= --without-cups
55 ifeq ($(BR2_PACKAGE_DBUS
),y
)
56 WINE_CONF_OPTS
+= --with-dbus
57 WINE_DEPENDENCIES
+= dbus
59 WINE_CONF_OPTS
+= --without-dbus
62 ifeq ($(BR2_PACKAGE_FONTCONFIG
),y
)
63 WINE_CONF_OPTS
+= --with-fontconfig
64 WINE_DEPENDENCIES
+= fontconfig
66 WINE_CONF_OPTS
+= --without-fontconfig
69 # To support freetype in wine we also need freetype in host-wine for the cross compiling tools
70 ifeq ($(BR2_PACKAGE_FREETYPE
),y
)
71 WINE_CONF_OPTS
+= --with-freetype
72 HOST_WINE_CONF_OPTS
+= --with-freetype
73 WINE_DEPENDENCIES
+= freetype
74 HOST_WINE_DEPENDENCIES
+= host-freetype
75 WINE_CONF_ENV
+= FREETYPE_CONFIG
=$(STAGING_DIR
)/usr
/bin
/freetype-config
77 WINE_CONF_OPTS
+= --without-freetype
78 HOST_WINE_CONF_OPTS
+= --without-freetype
81 ifeq ($(BR2_PACKAGE_GNUTLS
),y
)
82 WINE_CONF_OPTS
+= --with-gnutls
83 WINE_DEPENDENCIES
+= gnutls
85 WINE_CONF_OPTS
+= --without-gnutls
88 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE
),y
)
89 WINE_CONF_OPTS
+= --with-gstreamer
90 WINE_DEPENDENCIES
+= gst-plugins-base
92 WINE_CONF_OPTS
+= --without-gstreamer
95 ifeq ($(BR2_PACKAGE_JPEG
),y
)
96 WINE_CONF_OPTS
+= --with-jpeg
97 WINE_DEPENDENCIES
+= jpeg
99 WINE_CONF_OPTS
+= --without-jpeg
102 ifeq ($(BR2_PACKAGE_LCMS2
),y
)
103 WINE_CONF_OPTS
+= --with-cms
104 WINE_DEPENDENCIES
+= lcms2
106 WINE_CONF_OPTS
+= --without-cms
109 ifeq ($(BR2_PACKAGE_HAS_LIBGL
),y
)
110 WINE_CONF_OPTS
+= --with-opengl
111 WINE_DEPENDENCIES
+= libgl
113 WINE_CONF_OPTS
+= --without-opengl
116 ifeq ($(BR2_PACKAGE_LIBGLU
),y
)
117 WINE_CONF_OPTS
+= --with-glu
118 WINE_DEPENDENCIES
+= libglu
120 WINE_CONF_OPTS
+= --without-glu
123 ifeq ($(BR2_PACKAGE_LIBPCAP
),y
)
124 WINE_CONF_OPTS
+= --with-pcap
125 WINE_DEPENDENCIES
+= libpcap
127 WINE_CONF_OPTS
+= --without-pcap
130 ifeq ($(BR2_PACKAGE_LIBPNG
),y
)
131 WINE_CONF_OPTS
+= --with-png
132 WINE_DEPENDENCIES
+= libpng
134 WINE_CONF_OPTS
+= --without-png
137 ifeq ($(BR2_PACKAGE_LIBV4L
),y
)
138 WINE_CONF_OPTS
+= --with-v4l
139 WINE_DEPENDENCIES
+= libv4l
141 WINE_CONF_OPTS
+= --without-v4l
144 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
145 WINE_CONF_OPTS
+= --with-xml
146 WINE_DEPENDENCIES
+= libxml2
147 WINE_CONF_ENV
+= XML2_CONFIG
=$(STAGING_DIR
)/usr
/bin
/xml2-config
149 WINE_CONF_OPTS
+= --without-xml
152 ifeq ($(BR2_PACKAGE_LIBXSLT
),y
)
153 WINE_CONF_OPTS
+= --with-xslt
154 WINE_DEPENDENCIES
+= libxslt
155 WINE_CONF_ENV
+= XSLT_CONFIG
=$(STAGING_DIR
)/usr
/bin
/xslt-config
157 WINE_CONF_OPTS
+= --without-xslt
160 ifeq ($(BR2_PACKAGE_MPG123
),y
)
161 WINE_CONF_OPTS
+= --with-mpg123
162 WINE_DEPENDENCIES
+= mpg123
164 WINE_CONF_OPTS
+= --without-mpg123
167 ifeq ($(BR2_PACKAGE_NCURSES
),y
)
168 WINE_CONF_OPTS
+= --with-curses
169 WINE_DEPENDENCIES
+= ncurses
171 WINE_CONF_OPTS
+= --without-curses
174 ifeq ($(BR2_PACKAGE_OPENAL
),y
)
175 WINE_CONF_OPTS
+= --with-openal
176 WINE_DEPENDENCIES
+= openal
178 WINE_CONF_OPTS
+= --without-openal
181 ifeq ($(BR2_PACKAGE_OPENLDAP
),y
)
182 WINE_CONF_OPTS
+= --with-ldap
183 WINE_DEPENDENCIES
+= openldap
185 WINE_CONF_OPTS
+= --without-ldap
188 ifeq ($(BR2_PACKAGE_MESA3D_OSMESA
),y
)
189 WINE_CONF_OPTS
+= --with-osmesa
190 WINE_DEPENDENCIES
+= mesa3d
192 WINE_CONF_OPTS
+= --without-osmesa
195 ifeq ($(BR2_PACKAGE_PULSEAUDIO
),y
)
196 WINE_CONF_OPTS
+= --with-pulse
197 WINE_DEPENDENCIES
+= pulseaudio
199 WINE_CONF_OPTS
+= --without-pulse
202 ifeq ($(BR2_PACKAGE_SAMBA4
),y
)
203 WINE_CONF_OPTS
+= --with-netapi
204 WINE_DEPENDENCIES
+= samba4
206 WINE_CONF_OPTS
+= --without-netapi
209 ifeq ($(BR2_PACKAGE_SANE_BACKENDS
),y
)
210 WINE_CONF_OPTS
+= --with-sane
211 WINE_DEPENDENCIES
+= sane-backends
212 WINE_CONF_ENV
+= SANE_CONFIG
=$(STAGING_DIR
)/usr
/bin
/sane-config
214 WINE_CONF_OPTS
+= --without-sane
217 ifeq ($(BR2_PACKAGE_TIFF
),y
)
218 WINE_CONF_OPTS
+= --with-tiff
219 WINE_DEPENDENCIES
+= tiff
221 WINE_CONF_OPTS
+= --without-tiff
224 ifeq ($(BR2_PACKAGE_XLIB_LIBX11
),y
)
225 WINE_CONF_OPTS
+= --with-x
226 WINE_DEPENDENCIES
+= xlib_libX11
228 WINE_CONF_OPTS
+= --without-x
231 ifeq ($(BR2_PACKAGE_XLIB_LIBXCOMPOSITE
),y
)
232 WINE_CONF_OPTS
+= --with-xcomposite
233 WINE_DEPENDENCIES
+= xlib_libXcomposite
235 WINE_CONF_OPTS
+= --without-xcomposite
238 ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR
),y
)
239 WINE_CONF_OPTS
+= --with-xcursor
240 WINE_DEPENDENCIES
+= xlib_libXcursor
242 WINE_CONF_OPTS
+= --without-xcursor
245 ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT
),y
)
246 WINE_CONF_OPTS
+= --with-xshape
--with-xshm
247 WINE_DEPENDENCIES
+= xlib_libXext
249 WINE_CONF_OPTS
+= --without-xshape
--without-xshm
252 ifeq ($(BR2_PACKAGE_XLIB_LIBXI
),y
)
253 WINE_CONF_OPTS
+= --with-xinput
--with-xinput2
254 WINE_DEPENDENCIES
+= xlib_libXi
256 WINE_CONF_OPTS
+= --without-xinput
--without-xinput2
259 ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA
),y
)
260 WINE_CONF_OPTS
+= --with-xinerama
261 WINE_DEPENDENCIES
+= xlib_libXinerama
263 WINE_CONF_OPTS
+= --without-xinerama
266 ifeq ($(BR2_PACKAGE_XLIB_LIBXRANDR
),y
)
267 WINE_CONF_OPTS
+= --with-xrandr
268 WINE_DEPENDENCIES
+= xlib_libXrandr
270 WINE_CONF_OPTS
+= --without-xrandr
273 ifeq ($(BR2_PACKAGE_XLIB_LIBXRENDER
),y
)
274 WINE_CONF_OPTS
+= --with-xrender
275 WINE_DEPENDENCIES
+= xlib_libXrender
277 WINE_CONF_OPTS
+= --without-xrender
280 ifeq ($(BR2_PACKAGE_XLIB_LIBXXF86VM
),y
)
281 WINE_CONF_OPTS
+= --with-xxf86vm
282 WINE_DEPENDENCIES
+= xlib_libXxf86vm
284 WINE_CONF_OPTS
+= --without-xxf86vm
287 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
288 WINE_CONF_OPTS
+= --with-zlib
289 WINE_DEPENDENCIES
+= zlib
291 WINE_CONF_OPTS
+= --without-zlib
294 # host-gettext is essential for .po file support in host-wine wrc
295 HOST_WINE_DEPENDENCIES
+= host-gettext
296 HOST_WINE_CONF_OPTS
+= --with-gettext
--with-gettextpo
298 # Wine needs to enable 64-bit build tools on 64-bit host
299 ifeq ($(HOSTARCH
),x86_64
)
300 HOST_WINE_CONF_OPTS
+= --enable-win64
303 # Wine only needs the host tools to be built, so cut-down the
304 # build time by building just what we need.
305 define HOST_WINE_BUILD_CMDS
306 $(HOST_MAKE_ENV
) $(MAKE
) -C
$(@D
) \
316 # Wine only needs its host variant to be built, not that it is
317 # installed, as it uses the tools from the build directory. But
318 # we have no way in Buildroot to state that a host package should
319 # not be installed. So, just provide an noop install command.
320 define HOST_WINE_INSTALL_CMDS
324 # We are focused on the cross compiling tools, disable everything else
325 HOST_WINE_CONF_OPTS
+= \
331 --without-coreaudio \
335 --without-fontconfig \
340 --without-gstreamer \
358 --without-xcomposite \
372 $(eval
$(autotools-package
))
373 $(eval
$(host-autotools-package
))