raptor: new package
[buildroot-gz.git] / package / raptor / raptor.mk
blobaea14e393f6177494545c743b3e5b7445efec272
1 ################################################################################
3 # raptor
5 ################################################################################
7 RAPTOR_VERSION = 2.0.15
8 RAPTOR_SOURCE = raptor2-$(RAPTOR_VERSION).tar.gz
9 RAPTOR_SITE = http://download.librdf.org/source
10 RAPTOR_DEPENDENCIES = libxml2 libxslt
11 RAPTOR_LICENSE = GPLv2+ or LGPLv2.1+ or Apache-2.0+
12 RAPTOR_LICENSE_FILES = LICENSE.txt
14 # Flag is added to make sure the patch is applied for the configure.ac of raptor.
15 RAPTOR_AUTORECONF = YES
17 RAPTOR_CONF_OPTS =\
18 --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config \
19 --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config
21 ifeq ($(BR2_PACKAGE_LIBCURL),y)
22 RAPTOR_DEPENDENCIES += libcurl
23 RAPTOR_CONF_OPTS += --with-curl-config=$(STAGING_DIR)/usr/bin/curl-config
24 else
25 RAPTOR_CONF_OPTS += --with-curl-config=no
26 endif
28 ifeq ($(BR2_PACKAGE_YAJL),y)
29 RAPTOR_DEPENDENCIES += yajl
30 RAPTOR_CONF_ENV += LIBS="-lm"
31 RAPTOR_CONF_OPTS += --with-yajl=$(STAGING_DIR)/usr
32 else
33 RAPTOR_CONF_OPTS += --with-yajl=no
34 endif
36 ifeq ($(BR2_PACKAGE_ICU),y)
37 RAPTOR_DEPENDENCIES += icu
38 RAPTOR_CONF_OPTS += --with-icu-config=$(STAGING_DIR)/usr/bin/icu-config
39 else
40 RAPTOR_CONF_OPTS += --with-icu-config=no
41 endif
43 $(eval $(autotools-package))