perl-cross: bump to version 1.1.4
[buildroot-gz.git] / package / dcron / dcron.mk
blob7e81b63803e0657412bee811d915e1b9f581b1e2
1 ################################################################################
3 # dcron
5 ################################################################################
7 DCRON_VERSION = 4.5
8 DCRON_SITE = http://www.jimpryor.net/linux/releases
9 # The source code does not specify the version of the GPL that is used.
10 DCRON_LICENSE = GPL
12 # Overwrite cron-related Busybox commands if available
13 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
14 DCRON_DEPENDENCIES = busybox
15 endif
17 define DCRON_BUILD_CMDS
18 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
19 endef
21 define DCRON_INSTALL_TARGET_CMDS
22 $(INSTALL) -D -m0700 $(@D)/crond $(TARGET_DIR)/usr/sbin/crond
23 $(INSTALL) -D -m4755 $(@D)/crontab $(TARGET_DIR)/usr/bin/crontab
24 $(INSTALL) -D -m0644 $(@D)/extra/root.crontab $(TARGET_DIR)/etc/cron.d/system
25 # Busybox provides run-parts, so there is no need to use nor install provided run-cron
26 $(SED) 's#/usr/sbin/run-cron#/bin/run-parts#g' $(TARGET_DIR)/etc/cron.d/system
27 $(INSTALL) -d -m0755 $(TARGET_DIR)/var/spool/cron/crontabs \
28 $(TARGET_DIR)/etc/cron.daily $(TARGET_DIR)/etc/cron.hourly \
29 $(TARGET_DIR)/etc/cron.monthly $(TARGET_DIR)/etc/cron.weekly
30 endef
32 define DCRON_INSTALL_INIT_SYSV
33 $(INSTALL) -D -m 0755 package/dcron/S90dcron $(TARGET_DIR)/etc/init.d/S90dcron
34 endef
36 define DCRON_INSTALL_INIT_SYSTEMD
37 $(INSTALL) -D -m 644 package/dcron/dcron.service \
38 $(TARGET_DIR)/usr/lib/systemd/system/dcron.service
39 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
40 ln -sf ../../../../usr/lib/systemd/system/dcron.service \
41 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/dcron.service
42 endef
44 $(eval $(generic-package))