scancpan: fix detection of native module
[buildroot-gz.git] / package / poppler / poppler.mk
blob6142cbaf90dc401830178dc2589465b27c0be6b5
1 ################################################################################
3 # poppler
5 ################################################################################
7 POPPLER_VERSION = 0.32.0
8 POPPLER_SOURCE = poppler-$(POPPLER_VERSION).tar.xz
9 POPPLER_SITE = http://poppler.freedesktop.org
10 POPPLER_DEPENDENCIES = fontconfig host-pkgconf
11 POPPLER_LICENSE = GPLv2+
12 POPPLER_LICENSE_FILES = COPYING
13 POPPLER_INSTALL_STAGING = YES
14 POPPLER_CONF_OPTS = --with-font-configuration=fontconfig
16 ifeq ($(BR2_PACKAGE_LCMS2),y)
17 POPPLER_CONF_OPTS += --enable-cms=lcms2
18 POPPLER_DEPENDENCIES += lcms2
19 else
20 POPPLER_CONF_OPTS += --enable-cms=none
21 endif
23 ifeq ($(BR2_PACKAGE_TIFF),y)
24 POPPLER_CONF_OPTS += --enable-libtiff
25 # Help poppler to find libtiff in static linking scenarios
26 POPPLER_CONF_ENV += \
27 LIBTIFF_LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libtiff-4`"
28 POPPLER_DEPENDENCIES += tiff
29 else
30 POPPLER_CONF_OPTS += --disable-libtiff
31 endif
33 ifeq ($(BR2_PACKAGE_JPEG),y)
34 POPPLER_CONF_OPTS += --enable-libjpeg
35 POPPLER_DEPENDENCIES += jpeg
36 else
37 POPPLER_CONF_OPTS += --disable-libjpeg
38 endif
40 ifeq ($(BR2_PACKAGE_LIBPNG),y)
41 POPPLER_CONF_OPTS += --enable-libpng
42 POPPLER_DEPENDENCIES += libpng
43 else
44 POPPLER_CONF_OPTS += --disable-libpng
45 endif
47 ifeq ($(BR2_PACKAGE_ZLIB),y)
48 POPPLER_CONF_OPTS += --enable-zlib
49 POPPLER_DEPENDENCIES += zlib
50 else
51 POPPLER_CONF_OPTS += --disable-zlib
52 endif
54 ifeq ($(BR2_PACKAGE_POPPLER_LIBCURL),y)
55 POPPLER_CONF_OPTS += --enable-libcurl
56 POPPLER_DEPENDENCIES += libcurl
57 else
58 POPPLER_CONF_OPTS += --disable-libcurl
59 endif
61 ifeq ($(BR2_PACKAGE_XORG7),y)
62 POPPLER_CONF_OPTS += --with-x
63 POPPLER_DEPENDENCIES += xlib_libX11 xlib_libXext
64 else
65 POPPLER_CONF_OPTS += --without-x
66 endif
68 ifeq ($(BR2_PACKAGE_POPPLER_QT),y)
69 POPPLER_DEPENDENCIES += qt
70 POPPLER_CONF_OPTS += --enable-poppler-qt4
71 else
72 POPPLER_CONF_OPTS += --disable-poppler-qt4
73 endif
75 ifeq ($(BR2_PACKAGE_OPENJPEG),y)
76 POPPLER_DEPENDENCIES += openjpeg
77 POPPLER_CONF_OPTS += --enable-libopenjpeg=openjpeg1
78 else
79 POPPLER_CONF_OPTS += --enable-libopenjpeg=none
80 endif
82 $(eval $(autotools-package))