scancpan: fix detection of native module
[buildroot-gz.git] / package / sdl_mixer / sdl_mixer.mk
bloba602b6e966536c375ce7ef9659baf8281b5a7ca9
1 ################################################################################
3 # sdl_mixer
5 ################################################################################
7 SDL_MIXER_VERSION = 1.2.12
8 SDL_MIXER_SOURCE = SDL_mixer-$(SDL_MIXER_VERSION).tar.gz
9 SDL_MIXER_SITE = http://www.libsdl.org/projects/SDL_mixer/release
10 SDL_MIXER_LICENSE = zlib
11 SDL_MIXER_LICENSE_FILES = COPYING
13 SDL_MIXER_INSTALL_STAGING = YES
14 SDL_MIXER_DEPENDENCIES = sdl
15 SDL_MIXER_CONF_OPTS = \
16 --without-x \
17 --with-sdl-prefix=$(STAGING_DIR)/usr \
18 --disable-music-midi \
19 --disable-music-mod \
20 --disable-music-mp3 \
21 --disable-music-flac # configure script fails when cross compiling
23 ifeq ($(BR2_PACKAGE_LIBMAD),y)
24 SDL_MIXER_CONF_OPTS += --enable-music-mp3-mad-gpl
25 SDL_MIXER_DEPENDENCIES += libmad
26 else
27 SDL_MIXER_CONF_OPTS += --disable-music-mp3-mad-gpl
28 endif
30 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
31 SDL_MIXER_CONF_OPTS += --enable-music-ogg
32 SDL_MIXER_DEPENDENCIES += libvorbis
33 else
34 SDL_MIXER_CONF_OPTS += --disable-music-ogg
35 endif
37 $(eval $(autotools-package))