1 ################################################################################
5 ################################################################################
8 DOOM_WAD_SOURCE
= doom
$(subst .
,,$(DOOM_WAD_VERSION
))s.zip
9 # Official server currently unavailable
10 # DOOM_WAD_SITE = ftp://ftp.idsoftware.com/idstuff/doom
11 DOOM_WAD_SITE
= http
://www.jbserver.com
/downloads
/games
/doom
/misc
/shareware
13 define DOOM_WAD_EXTRACT_CMDS
14 $(UNZIP
) -p
$(DL_DIR
)/$($(PKG
)_SOURCE
) 'DOOMS_19.[12]' > \
15 $(@D
)/doom-
$(DOOM_WAD_VERSION
).zip
16 $(UNZIP
) -d
$(@D
) $(@D
)/doom-
$(DOOM_WAD_VERSION
).zip DOOM1.WAD
19 define DOOM_WAD_INSTALL_TARGET_CMDS
20 $(INSTALL
) -m
0644 -D
$(@D
)/DOOM1.WAD \
21 $(TARGET_DIR
)/usr
/share
/games
/doom
/doom1.wad
24 $(eval
$(generic-package
))