pkg-perl: set PERL_USE_UNSAFE_INC
[buildroot-gz.git] / package / doom-wad / doom-wad.mk
blobd3ac731bd5d313ff3e23fc8d2e5022950b31a9b2
1 ################################################################################
3 # doom-wad
5 ################################################################################
7 DOOM_WAD_VERSION = 1.9
8 DOOM_WAD_SOURCE = doom$(subst .,,$(DOOM_WAD_VERSION))s.zip
9 # Official server currently unavailable
10 # DOOM_WAD_SITE = ftp://ftp.idsoftware.com/idstuff/doom
11 DOOM_WAD_SITE = http://www.jbserver.com/downloads/games/doom/misc/shareware
13 define DOOM_WAD_EXTRACT_CMDS
14 $(UNZIP) -p $(DL_DIR)/$($(PKG)_SOURCE) 'DOOMS_19.[12]' > \
15 $(@D)/doom-$(DOOM_WAD_VERSION).zip
16 $(UNZIP) -d $(@D) $(@D)/doom-$(DOOM_WAD_VERSION).zip DOOM1.WAD
17 endef
19 define DOOM_WAD_INSTALL_TARGET_CMDS
20 $(INSTALL) -m 0644 -D $(@D)/DOOM1.WAD \
21 $(TARGET_DIR)/usr/share/games/doom/doom1.wad
22 endef
24 $(eval $(generic-package))