1 ################################################################################
5 ################################################################################
7 WAYLAND_VERSION
= 1.13.0
8 WAYLAND_SITE
= http
://wayland.freedesktop.org
/releases
9 WAYLAND_SOURCE
= wayland-
$(WAYLAND_VERSION
).
tar.xz
11 WAYLAND_LICENSE_FILES
= COPYING
12 WAYLAND_INSTALL_STAGING
= YES
13 WAYLAND_DEPENDENCIES
= host-pkgconf host-wayland expat libffi libxml2
14 HOST_WAYLAND_DEPENDENCIES
= host-pkgconf host-expat host-libffi host-libxml2
16 # 0002-configure-add-option-to-disable-tests.patch
17 WAYLAND_AUTORECONF
= YES
19 # wayland-scanner is only needed for building, not on the target
20 WAYLAND_CONF_OPTS
= --with-host-scanner
--disable-tests
21 HOST_WAYLAND_CONF_OPTS
= --disable-tests
23 # Remove the DTD from the target, it's not needed at runtime
24 define WAYLAND_TARGET_CLEANUP
25 rm -rf
$(TARGET_DIR
)/usr
/share
/wayland
27 WAYLAND_POST_INSTALL_TARGET_HOOKS
+= WAYLAND_TARGET_CLEANUP
29 $(eval
$(autotools-package
))
30 $(eval
$(host-autotools-package
))