fs/tar: make --no-recursion effective
[buildroot-gz.git] / package / flac / flac.mk
blobb819064c236d9f6d135644a0886dad8d6a210dad
1 ################################################################################
3 # flac
5 ################################################################################
7 FLAC_VERSION = 1.3.1
8 FLAC_SITE = http://downloads.xiph.org/releases/flac
9 FLAC_SOURCE = flac-$(FLAC_VERSION).tar.xz
10 FLAC_INSTALL_STAGING = YES
11 FLAC_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
12 FLAC_LICENSE = Xiph BSD-like (libFLAC), GPLv2+ (tools), LGPLv2.1+ (other libraries)
13 FLAC_LICENSE_FILES = COPYING.Xiph COPYING.GPL COPYING.LGPL
14 FLAC_CONF_OPTS = \
15 --disable-cpplibs \
16 --disable-xmms-plugin \
17 --disable-altivec
19 ifeq ($(BR2_PACKAGE_LIBOGG),y)
20 FLAC_CONF_OPTS += --with-ogg=$(STAGING_DIR)/usr
21 FLAC_DEPENDENCIES += libogg
22 else
23 FLAC_CONF_OPTS += --disable-ogg
24 endif
26 ifeq ($(BR2_X86_CPU_HAS_SSE),y)
27 FLAC_DEPENDENCIES += host-nasm
28 FLAC_CONF_OPTS += --enable-sse
29 else
30 FLAC_CONF_OPTS += --disable-sse
31 endif
33 $(eval $(autotools-package))