fs/tar: make --no-recursion effective
[buildroot-gz.git] / package / openvmtools / openvmtools.mk
blob40a7dac098bfd0e6c9d62f9eb3093884ef8213d0
1 ################################################################################
3 # openvmtools
5 ################################################################################
7 OPENVMTOOLS_VERSION = stable-9.10.2
8 OPENVMTOOLS_SITE = $(call github,vmware,open-vm-tools,$(OPENVMTOOLS_VERSION))
9 OPENVMTOOLS_SUBDIR = open-vm-tools
10 OPENVMTOOLS_LICENSE = LGPLv2.1
11 OPENVMTOOLS_LICENSE_FILES = $(OPENVMTOOLS_SUBDIR)/COPYING
12 # Autoreconf needed or config/missing will run configure again at buildtime
13 OPENVMTOOLS_AUTORECONF = YES
14 OPENVMTOOLS_CONF_OPTS = --with-dnet \
15 --without-icu --without-x --without-gtk2 \
16 --without-gtkmm --without-kernel-modules \
17 --disable-deploypkg --without-xerces
18 OPENVMTOOLS_CONF_ENV += CUSTOM_DNET_CPPFLAGS=" "
19 OPENVMTOOLS_DEPENDENCIES = libglib2 libdnet
21 # When libfuse is available, openvmtools can build vmblock-fuse, so
22 # make sure that libfuse gets built first
23 ifeq ($(BR2_PACKAGE_LIBFUSE),y)
24 OPENVMTOOLS_DEPENDENCIES += libfuse
25 endif
27 ifeq ($(BR2_PACKAGE_OPENSSL),y)
28 OPENVMTOOLS_CONF_OPTS += --with-ssl
29 OPENVMTOOLS_DEPENDENCIES += openssl
30 else
31 OPENVMTOOLS_CONF_OPTS += --without-ssl
32 endif
34 ifeq ($(BR2_PACKAGE_OPENVMTOOLS_PROCPS),y)
35 OPENVMTOOLS_CONF_OPTS += --with-procps
36 OPENVMTOOLS_DEPENDENCIES += procps-ng
37 else
38 OPENVMTOOLS_CONF_OPTS += --without-procps
39 endif
41 ifeq ($(BR2_PACKAGE_OPENVMTOOLS_PAM),y)
42 OPENVMTOOLS_CONF_OPTS += --with-pam
43 OPENVMTOOLS_DEPENDENCIES += linux-pam
44 else
45 OPENVMTOOLS_CONF_OPTS += --without-pam
46 endif
48 # configure needs execution permission
49 define OPENVMTOOLS_PRE_CONFIGURE_CHMOD
50 chmod 0755 $(@D)/$(OPENVMTOOLS_SUBDIR)/configure
51 endef
53 OPENVMTOOLS_PRE_CONFIGURE_HOOKS += OPENVMTOOLS_PRE_CONFIGURE_CHMOD
55 # symlink needed by lib/system/systemLinux.c (or will cry in /var/log/messages)
56 # defined in lib/misc/hostinfoPosix.c
57 # /sbin/shutdown needed for Guest OS restart/shutdown from hypervisor
58 define OPENVMTOOLS_POST_INSTALL_TARGET_THINGIES
59 ln -fs os-release $(TARGET_DIR)/etc/lfs-release
60 if [ ! -e $(TARGET_DIR)/sbin/shutdown ]; then \
61 $(INSTALL) -D -m 755 package/openvmtools/shutdown \
62 $(TARGET_DIR)/sbin/shutdown; \
64 endef
66 OPENVMTOOLS_POST_INSTALL_TARGET_HOOKS += OPENVMTOOLS_POST_INSTALL_TARGET_THINGIES
68 define OPENVMTOOLS_INSTALL_INIT_SYSV
69 $(INSTALL) -D -m 755 package/openvmtools/S10vmtoolsd \
70 $(TARGET_DIR)/etc/init.d/S10vmtoolsd
71 endef
73 define OPENVMTOOLS_INSTALL_INIT_SYSTEMD
74 $(INSTALL) -D -m 644 package/openvmtools/vmtoolsd.service \
75 $(TARGET_DIR)/usr/lib/systemd/system/vmtoolsd.service
76 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
77 ln -fs ../../../../usr/lib/systemd/system/vmtoolsd.service \
78 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/vmtoolsd.service
79 endef
81 $(eval $(autotools-package))