1 ################################################################################
5 ################################################################################
7 SYSLOG_NG_VERSION
= 3.7.3
8 SYSLOG_NG_SOURCE
= syslog-ng-
$(SYSLOG_NG_VERSION
).
tar.gz
9 SYSLOG_NG_SITE
= https
://github.com
/balabit
/syslog-ng
/releases
/download
/syslog-ng-
$(SYSLOG_NG_VERSION
)
10 SYSLOG_NG_LICENSE
= LGPLv2.1
+ (syslog-ng core
), GPLv2
+ (modules
)
11 SYSLOG_NG_LICENSE_FILES
= COPYING
12 SYSLOG_NG_DEPENDENCIES
= host-bison host-flex host-pkgconf \
13 eventlog libglib2 openssl pcre
14 # rabbit-mq needs -lrt
15 SYSLOG_NG_CONF_ENV
= LIBS
=-lrt
16 SYSLOG_NG_CONF_OPTS
= --disable-manpages
--localstatedir
=/var
/run
18 # We override busybox's S01logging init script
19 ifeq ($(BR2_PACKAGE_BUSYBOX
),y
)
20 SYSLOG_NG_DEPENDENCIES
+= busybox
23 ifeq ($(BR2_PACKAGE_GEOIP
),y
)
24 SYSLOG_NG_DEPENDENCIES
+= geoip
25 SYSLOG_NG_CONF_OPTS
+= --enable-geoip
27 SYSLOG_NG_CONF_OPTS
+= --disable-geoip
30 ifeq ($(BR2_PACKAGE_LIBCAP
),y
)
31 SYSLOG_NG_DEPENDENCIES
+= libcap
32 SYSLOG_NG_CONF_OPTS
+= --enable-linux-caps
34 SYSLOG_NG_CONF_OPTS
+= --disable-linux-caps
37 ifeq ($(BR2_PACKAGE_PYTHON
),y
)
38 SYSLOG_NG_DEPENDENCIES
+= python
39 SYSLOG_NG_CONF_OPTS
+= \
41 --with-python
=$(PYTHON_VERSION_MAJOR
)
42 else ifeq ($(BR2_PACKAGE_PYTHON3
),y
)
43 SYSLOG_NG_DEPENDENCIES
+= python3
44 SYSLOG_NG_CONF_OPTS
+= \
46 --with-python
=$(PYTHON3_VERSION_MAJOR
)
48 SYSLOG_NG_CONF_OPTS
+= \
53 ifeq ($(BR2_PACKAGE_LIBESMTP
),y
)
54 SYSLOG_NG_DEPENDENCIES
+= libesmtp
55 SYSLOG_NG_CONF_OPTS
+= --enable-smtp
56 SYSLOG_NG_CONF_OPTS
+= --with-libesmtp
="$(STAGING_DIR)/usr"
58 SYSLOG_NG_CONF_OPTS
+= --disable-smtp
61 ifeq ($(BR2_PACKAGE_JSON_C
),y
)
62 SYSLOG_NG_DEPENDENCIES
+= json-c
63 SYSLOG_NG_CONF_OPTS
+= --enable-json
65 SYSLOG_NG_CONF_OPTS
+= --disable-json
68 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID
),y
)
69 SYSLOG_NG_DEPENDENCIES
+= util-linux
72 ifeq ($(BR2_PACKAGE_LIBNET
),y
)
73 SYSLOG_NG_DEPENDENCIES
+= libnet
74 SYSLOG_NG_CONF_OPTS
+= --enable-spoof-source
76 SYSLOG_NG_CONF_OPTS
+= --disable-spoof-source
79 ifeq ($(BR2_INIT_SYSTEMD
),y
)
80 SYSLOG_NG_DEPENDENCIES
+= systemd
81 SYSLOG_NG_CONF_OPTS
+= \
83 --with-systemdsystemunitdir
=/usr
/lib
/systemd
/system
85 SYSLOG_NG_CONF_OPTS
+= --disable-systemd
88 define SYSLOG_NG_INSTALL_INIT_SYSV
89 $(INSTALL
) -m
0755 -D package
/syslog-ng
/S01logging \
90 $(TARGET_DIR
)/etc
/init.d
/S01logging
93 # By default syslog-ng installs a number of sample configuration
94 # files. Some of these rely on optional features being
95 # enabled. Because of this buildroot uninstalls the shipped config
96 # files and provides a simplified configuration.
97 define SYSLOG_NG_FIXUP_CONFIG
98 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) \
99 DESTDIR
=$(TARGET_DIR
) scl-uninstall-local
100 $(INSTALL
) -D
-m
0644 package
/syslog-ng
/syslog-ng.conf \
101 $(TARGET_DIR
)/etc
/syslog-ng.conf
104 SYSLOG_NG_POST_INSTALL_TARGET_HOOKS
= SYSLOG_NG_FIXUP_CONFIG
106 $(eval
$(autotools-package
))