1 ################################################################################
5 ################################################################################
8 IFPLUGD_SITE
= http
://0pointer.de
/lennart
/projects
/ifplugd
9 IFPLUGD_LICENSE
= GPLv2
10 IFPLUGD_LICENSE_FILES
= LICENSE
11 IFPLUGD_AUTORECONF
= YES
13 # install-strip unconditionally overwrites $(TARGET_DIR)/etc/ifplugd/ifplugd.*
14 IFPLUGD_INSTALL_TARGET_OPTS
= DESTDIR
=$(TARGET_DIR
) install-exec
15 IFPLUGD_CONF_OPTS
= --disable-lynx
--with-initdir
=/etc
/init.d
/
16 IFPLUGD_DEPENDENCIES
= libdaemon
19 ifeq ($(BR2_PACKAGE_BUSYBOX
),y
)
20 IFPLUGD_DEPENDENCIES
+= busybox
23 define IFPLUGD_INSTALL_FIXUP
24 $(INSTALL
) -D
-m
0644 $(@D
)/conf
/ifplugd.conf
$(TARGET_DIR
)/etc
/ifplugd
/ifplugd.conf
; \
25 $(SED
) 's^\(ARGS=.*\)w^\1^' $(TARGET_DIR
)/etc
/ifplugd
/ifplugd.conf
; \
26 $(INSTALL
) -D
-m
0755 $(@D
)/conf
/ifplugd.action \
27 $(TARGET_DIR
)/etc
/ifplugd
/ifplugd.action
30 IFPLUGD_POST_INSTALL_TARGET_HOOKS
+= IFPLUGD_INSTALL_FIXUP
32 define IFPLUGD_INSTALL_INIT_SYSV
33 $(INSTALL
) -D
-m
0755 $(@D
)/conf
/ifplugd.init \
34 $(TARGET_DIR
)/etc
/init.d
/S45ifplugd
35 # don't use bash for init script
36 $(SED
) 's^/bin/bash^/bin/sh^g' $(TARGET_DIR
)/etc
/init.d
/S45ifplugd
39 $(eval
$(autotools-package
))