1 ################################################################################
5 ################################################################################
7 RPM_VERSION_MAJOR
= 5.2
8 RPM_VERSION
= $(RPM_VERSION_MAJOR
).0
9 RPM_SITE
= http
://rpm5.org
/files
/rpm
/rpm-
$(RPM_VERSION_MAJOR
)
10 RPM_DEPENDENCIES
= host-pkgconf zlib beecrypt neon popt openssl
11 RPM_LICENSE
= LGPLv2.1
12 RPM_LICENSE_FILES
= COPYING.LIB
15 CFLAGS
="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/beecrypt -I$(STAGING_DIR)/usr/include/neon -DHAVE_MUTEX_THREAD_ONLY" \
19 --disable-build-versionscript \
24 --with-openssl
=external \
25 --with-zlib
=external \
26 --with-libbeecrypt
=$(STAGING_DIR
) \
29 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE
),y
)
30 RPM_DEPENDENCIES
+= gettext
33 ifeq ($(BR2_PACKAGE_PCRE
),y
)
34 RPM_DEPENDENCIES
+= pcre
35 RPM_CONF_OPTS
+= --with-pcre
=external
37 RPM_CONF_OPTS
+= --with-pcre
=none
40 ifeq ($(BR2_PACKAGE_FILE
),y
)
41 RPM_DEPENDENCIES
+= file
42 RPM_CONF_OPTS
+= --with-file
=external
44 RPM_CONF_OPTS
+= --with-file
=none
47 # xz payload support needs a toolchain w/ C++
48 ifeq ($(BR2_PACKAGE_XZ
)$(BR2_INSTALL_LIBSTDCPP
),yy
)
49 RPM_DEPENDENCIES
+= xz
50 RPM_CONF_OPTS
+= --with-xz
=external
52 RPM_CONF_OPTS
+= --with-xz
=none
55 ifeq ($(BR2_PACKAGE_BZIP2
),y
)
56 RPM_CONF_OPTS
+= --with-bzip2
57 RPM_DEPENDENCIES
+= bzip2
62 RPM_INSTALL_TARGET_OPTS
= DESTDIR
=$(TARGET_DIR
) program_transform_name
= install
64 $(eval
$(autotools-package
))