docker-engine: new package
[buildroot-gz.git] / package / wireless_tools / wireless_tools.mk
blobcb15412f536b1900df532c4362e0c78824264d83
1 ################################################################################
3 # wireless_tools
5 ################################################################################
7 WIRELESS_TOOLS_VERSION_MAJOR = 30
8 WIRELESS_TOOLS_VERSION = $(WIRELESS_TOOLS_VERSION_MAJOR).pre9
9 WIRELESS_TOOLS_SITE = http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
10 WIRELESS_TOOLS_SOURCE = wireless_tools.$(WIRELESS_TOOLS_VERSION).tar.gz
11 WIRELESS_TOOLS_LICENSE = GPLv2
12 WIRELESS_TOOLS_LICENSE_FILES = COPYING
13 WIRELESS_TOOLS_INSTALL_STAGING = YES
15 WIRELESS_TOOLS_BUILD_TARGETS = iwmulticall
16 WIRELESS_TOOLS_INSTALL_TARGETS = install-iwmulticall
18 ifeq ($(BR2_PACKAGE_WIRELESS_TOOLS_LIB),y)
19 WIRELESS_TOOLS_BUILD_TARGETS += libiw.so.$(WIRELESS_TOOLS_VERSION_MAJOR)
20 WIRELESS_TOOLS_INSTALL_TARGETS += install-dynamic
22 define WIRELESS_TOOLS_INSTALL_STAGING_CMDS
23 $(MAKE) -C $(@D) PREFIX="$(STAGING_DIR)" LDCONFIG=/bin/true \
24 install-dynamic
25 $(MAKE) -C $(@D) PREFIX="$(STAGING_DIR)/usr" install-hdr
26 endef
28 endif
30 define WIRELESS_TOOLS_BUILD_CMDS
31 $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
32 $(WIRELESS_TOOLS_BUILD_TARGETS)
33 endef
35 define WIRELESS_TOOLS_INSTALL_TARGET_CMDS
36 $(MAKE) -C $(@D) PREFIX="$(TARGET_DIR)" LDCONFIG=/bin/true \
37 $(WIRELESS_TOOLS_INSTALL_TARGETS)
38 endef
40 $(eval $(generic-package))