1 ################################################################################
5 ################################################################################
7 TINYCBOR_VERSION
= v0.4
.1
8 TINYCBOR_SITE
= $(call github
,01org
,tinycbor
,$(TINYCBOR_VERSION
))
10 TINYCBOR_LICENSE_FILES
= LICENSE
12 TINYCBOR_DEPENDENCIES
= host-pkgconf
13 TINYCBOR_INSTALL_STAGING
= YES
15 # This patch fixes static build of json2cbor
17 https
://github.com
/01org
/tinycbor
/commit
/ae608ea2735bd331ec7dcf9d89928c38f0e0c981.patch
19 ifeq ($(BR2_PACKAGE_CJSON
),y
)
20 TINYCBOR_DEPENDENCIES
+= cjson
23 TINYCBOR_MAKE_OPTS
= $(TARGET_CONFIGURE_OPTS
) V
=1
25 # disabled parallel build because of build failures while
26 # producing the .config file
27 define TINYCBOR_BUILD_CMDS
28 $(TARGET_MAKE_ENV
) $(MAKE1
) $(TINYCBOR_MAKE_OPTS
) -C
$(@D
)
31 define TINYCBOR_INSTALL_STAGING_CMDS
32 $(TARGET_MAKE_ENV
) $(MAKE
) $(TINYCBOR_MAKE_OPTS
) -C
$(@D
) \
33 DESTDIR
=$(STAGING_DIR
) prefix=/usr
install
36 define TINYCBOR_INSTALL_TARGET_CMDS
37 $(TARGET_MAKE_ENV
) $(MAKE
) $(TINYCBOR_MAKE_OPTS
) -C
$(@D
) \
38 DESTDIR
=$(TARGET_DIR
) prefix=/usr
install
41 $(eval
$(generic-package
))