gcc: preserve CXXFLAGS_FOR_TARGET
[buildroot-gz.git] / package / opusfile / opusfile.mk
blobc8108d33ebd53be01cf348bcbb0c5061e52bcf5d
1 ################################################################################
3 # opusfile
5 ################################################################################
7 OPUSFILE_VERSION = 0.7
8 OPUSFILE_SITE = http://downloads.xiph.org/releases/opus
9 OPUSFILE_DEPENDENCIES = host-pkgconf libogg opus
10 OPUSFILE_LICENSE = BSD-3c
11 OPUSFILE_LICENSE_FILES = COPYING
12 OPUSFILE_INSTALL_STAGING = YES
14 ifeq ($(BR2_PACKAGE_OPENSSL),y)
15 OPUSFILE_DEPENDENCIES += openssl
16 else
17 OPUSFILE_CONF_OPTS += --disable-http
18 endif
20 # Use the same as opus package since it's a dep and we can't mix
21 ifeq ($(BR2_PACKAGE_OPUS_FIXED_POINT),y)
22 OPUSFILE_CONF_OPTS += --enable-fixed-point
23 endif
25 $(eval $(autotools-package))