1 ################################################################################
5 ################################################################################
8 TFTPD_SOURCE
= tftp-hpa-
$(TFTPD_VERSION
).
tar.xz
9 TFTPD_SITE
= $(BR2_KERNEL_MIRROR
)/software
/network
/tftp
/tftp-hpa
10 TFTPD_CONF_OPTS
= --without-tcpwrappers
12 # Override BusyBox implementations if BusyBox is enabled.
13 ifeq ($(BR2_PACKAGE_BUSYBOX
),y
)
14 TFTPD_DEPENDENCIES
+= busybox
17 define TFTPD_INSTALL_TARGET_CMDS
18 $(INSTALL
) -D
$(@D
)/tftp
/tftp
$(TARGET_DIR
)/usr
/bin
/tftp
19 $(INSTALL
) -D
$(@D
)/tftpd
/tftpd
$(TARGET_DIR
)/usr
/sbin
/tftpd
22 define TFTPD_INSTALL_INIT_SYSV
23 $(INSTALL
) -D
-m
0755 package
/tftpd
/S80tftpd-hpa
$(TARGET_DIR
)/etc
/init.d
/S80tftpd-hpa
26 $(eval
$(autotools-package
))