2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
9 #since we are building from .svn
10 +export DH_ALWAYS_EXCLUDE
=.svn
12 ifneq ($(DEB_HOST_ARCH
),powerpc
)
13 CFLAGS
=-ffast-math
-O3
-mmmx
-march
=pentium4
-msse
-msse2
-minline-all-stringops
-fprefetch-loop-arrays
-funroll-loops
14 # CFLAGS=-ffast-math -g -mmmx -march=pentium-mmx
15 CXXFLAGS
=$(CFLAGS
) -fno-check-new
16 CONFFLAGS
+=--enable-mmx
--enable-x86
--without-pic
19 ifneq (, $(findstring smp2
,$(DEB_BUILD_OPTIONS
)))
23 config.status
: configure
25 @if
[ -z
"$(CFLAGS)" ] ; then CFLAGS
="$(CFLAGS)" ; fi
;
26 @if
[ -z
"$(CXXFLAGS)" ] ; then CXXFLAGS
="$(CXXFLAGS)" ; fi
;
27 CFLAGS
="$(CFLAGS)" CXXFLAGS
="$(CXXFLAGS)" \
28 .
/configure
--prefix=/usr
$(CONFFLAGS
)
31 build-stamp
: config.status
34 docbook-to-man debian
/cinelerra.sgml
> debian
/cinelerra
.1
35 docbook-to-man debian
/mplexhi.sgml
> debian
/mplexhi
.1
36 docbook-to-man debian
/mplexlo.sgml
> debian
/mplexlo
.1
43 -rm -f debian
/cinelerra
.1
44 -rm -f debian
/mplexhi
.1
45 -rm -f debian
/mplexlo
.1
48 binary-indep
: checkroot build-stamp
49 binary-arch
: checkroot build-stamp
50 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tmp
51 chmod
-x debian
/tmp
/usr
/lib
/cinelerra
/*
52 chmod
+x debian
/tmp
/usr
/lib
/cinelerra
/fonts
53 chmod
-x debian
/tmp
/usr
/lib
/cinelerra
/fonts
/*
54 dh_install
--sourcedir
=debian
/tmp
--autodest
56 dh_installchangelogs
-a
62 # Since Cinelerra is far from stable, I prefer leaving the debug info
64 strip -x
-s
-R .comment
-R .note debian
/cinelerra
/usr
/lib
/cinelerra
/*.so
66 # AFAIK bootstraping should be gone now -- minmax
68 # Rename defaulttheme to blondtheme
69 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/blondtheme.so plugins/defaulttheme/data/*.png
71 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/bluedottheme.so plugins/bluedottheme/data/*.png
72 # guicast/bootstrap debian/cinelerra/usr/bin/cinelerra cinelerra/data/mode_*.png
73 # not present anymore?
74 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/microtheme.so plugins/microtheme/data/*.png
83 binary
: binary-indep binary-arch