1 Summary: Distributed
hash table storage
7 Group: System Environment
/Libraries
8 URL: http
://www.ioremap.net
/projects
/elliptics
9 Source0: %{name}-%{version}.tar.bz2
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
13 BuildRequires
: python26
-devel
, boost141
-python
, boost141
-devel
14 BuildRequires
: boost141
-iostreams
, boost141
-thread
, boost141
-python
, boost141
-system
16 BuildRequires
: python
-devel
, boost
-python
, boost
-devel
, boost
-iostreams
, boost
-thread
, boost
-python
, boost
-system
18 BuildRequires
: eblob
-devel
>= 0.17.1
19 BuildRequires
: smack
>= 0.5.0
20 BuildRequires
: leveldb
-devel
26 Elliptics network is a fault tolerant distributed
hash table
31 Summary: Development files
for %{name}
32 Group: Development
/Libraries
33 Requires: %{name} = %{version}-%{release}
37 Elliptics network is a fault tolerant distributed
hash table
40 This package contains libraries
, header files and developer documentation
41 needed
for developing software which uses the cairo graphics library.
44 Summary: Elliptics library Python binding
45 Group: Development
/Libraries
46 Requires: %{name} = %{version}-%{release}
49 Elliptics Python Language bindings.
53 Summary: Elliptics library Python binding
54 Group: Development
/Libraries
55 Requires: elliptics
-python
= %{version}-%{release}
58 %description python
-devel
59 Elliptics Python Language bindings development headers and libraries.
63 Summary: Elliptics library C
++ binding
64 Group: Development
/Libraries
65 Requires: elliptics
= %{version}-%{release}
69 Elliptics library C
++ language binding.
73 Summary: Elliptics library C
++ binding development headers and libraries
74 Group: Development
/Libraries
75 Requires: elliptics
-devel
= %{version}-%{release}
76 Requires: elliptics
-c
++ = %{version}-%{release}
79 %description c
++-devel
80 Elliptics library C
++ binding development headers and libraries
81 for building C
++ applications with elliptics.
87 export LDFLAGS
="
-Wl
,-z
,defs"
88 export DESTDIR
="
%{buildroot}"
90 export PYTHON
=/usr
/bin
/python26
91 CXXFLAGS
="
-pthread
-I
/usr
/include
/boost141" LDFLAGS
="
-L
/usr
/lib64
/boost141"
%{cmake} -DBoost_DIR
=/usr
/lib64
/boost141 .
99 make install DESTDIR
=%{buildroot}
100 rm -f
%{buildroot}%{_libdir}/*.a
101 rm -f
%{buildroot}%{_libdir}/*.la
103 %post -p
/sbin
/ldconfig
104 %postun -p
/sbin
/ldconfig
106 %post python
-p
/sbin
/ldconfig
107 %postun python
-p
/sbin
/ldconfig
109 %post c
++ -p
/sbin
/ldconfig
110 %postun c
++ -p
/sbin
/ldconfig
116 %defattr(-,root
,root
,-)
117 %doc README doc
/design_notes.txt doc
/io_storage_backend.txt
119 %{_libdir}/libelliptics.so.
*
120 %{_libdir}/libelliptics_client.so.
*
121 %{_libdir}/libelliptics_cocaine.so.
*
122 %{_libdir}/libelliptics_cache.so.
*
126 %defattr(-,root
,root
,-)
128 %{_libdir}/libelliptics.so
129 %{_libdir}/libelliptics_client.so
130 %{_libdir}/libelliptics_cocaine.so
131 %{_libdir}/libelliptics_cache.so
134 %defattr(-,root
,root
,-)
135 %{_libdir}/libelliptics_python.so.
*
136 %{python_sitelib}/elliptics
*
140 %defattr(-,root
,root
,-)
141 %{_libdir}/libelliptics_python.so
145 %defattr(-,root
,root
,-)
146 %{_libdir}/libelliptics_cpp.so.
*
150 %defattr(-,root
,root
,-)
151 %{_libdir}/libelliptics_cpp.so
155 * Thu Nov
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.7
156 - Fixed dnet_mix_states
() when ID is null
158 * Wed Nov
21 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.6
159 - Tune nonblocking pool growing policy
160 - All dnet_remove
*() functions should
return error
, if ack returned negative status.
161 - poll
() uses msecs as timeout
163 * Mon Nov
12 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.5
164 - Added atomic number of available IO threads
, only grow up pool
if we have blocked sph and there are no threads available.
166 * Mon Nov
12 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.4
167 - Added atomic number of available IO threads
, only grow up pool
if we have blocked sph and there are no threads available.
169 * Wed Nov
07 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.4
170 - Added temoporary debug
172 * Tue Nov
06 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.3
173 - Only enlarge non
-blocking pool when there is blocking sph
in the pool.
175 * Fri Nov
02 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.2
176 - Fixed python installation
in Lucid
177 - Remove signal setup
in library. Do not block signals on ioserv
exit
178 - Only write error message when real error occurs
in leveldb_backend_read
()
180 * Fri Oct
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.1
181 - Fixed precise build
183 * Fri Oct
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.2.0
184 - When creating new state we should not send auth
/join commands to itself
185 - Return back periodic route table check
186 - Added LevelDB backend
188 * Thu Oct
25 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.1.0
189 - Depend elliptics
-dev on elliptics with
(>= $
{Source-Version}) version
190 - Do not check
for n
->st when setting up new server node
191 - When it is called from dnet_server_node_create
()->dnet_state_create
()
192 - there is no n
->st
, and that's exactly the path where server
194 * Fri Oct
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.0.1
195 - Use autogenerated major
/minor elliptics versions. Whole version is being
read from debian
/changelog file
196 - Fix CMake file with missing boost libraries
197 - Bump ABI version
(missed from
2.18->2.19 upgrade
)
198 - Drop site
-packages from elliptics
-client
199 - Depend on
>= 0.9.4 cocaine
201 * Wed Oct
10 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.19.0.0
202 - Added sessions
- this allows to configure and
set per
-request parameters
(like groups
)
204 * Wed Oct
10 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.2
205 - Fixed reply size calculation
206 - Unify srw log rules
207 - Fixed pool growing policy
208 - Updated debian package rules
210 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.1
211 - When running recovery
-on
-read do not write io attribute header
213 * Mon Oct
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.3.0
214 - Grow IO pools on demand
215 - Added automatic recovery on
read command:
216 - if object didn't exist
in previously
read group
,
217 - it will be written when
read from the next group succeed
218 - Documentation update
219 - Added multicast autodiscovery
220 - If state is already exist
, do not fail with error
221 - Fixed the ugliest debian python installation
222 - Added new python bindings
223 - Do not try to run
command if srw was not initialized
224 - Populate cache on READ
command when DNET_IO_FLAGS_CACHE ioflag is
set
226 * Thu Sep
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.2.1
227 - Added c
++/python bindings
for cache write operations
(including timeout
)
228 - Added remove
-from
-disk cache operation
: when such flag is
set (at write
time)"
229 - if object is removed from cache
, it is also removed from disk
230 - Increase example number of non
-blocking io threads
231 - Added 'overwrite commits write' comment
233 * Mon Sep
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.2
234 - dnet_backend_log_raw
() should use dnet_backend_check_log_level
() to check log level
235 - Added startup stack size check
236 - Cocaine job has to be created only when it can be queued
238 * Fri Sep
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.1.1
241 * Thu Sep
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.18.0.1
242 - New interface
for execution
, reply and chaining
244 - Fixed server node cleanup bug when it destroyed locks first
while IO threads could still use them
245 - dnet_send_cmd_raw
() must always
wait for ack
246 - Fixed thread creation bug
in app_watcher when application does not exist
247 - Added
-g flag to elliptics build
248 - Use weak symbols instead of stubs
in client lib
, since server also links to it and
in Fedora it ends up using stubs from client lib
249 - Search
for 0mq only of cocaine is enabled
250 - Update debian packaging
251 - Fixed build
-depends
253 * Fri Aug
31 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.4
254 - elliptics
-client must replace old
-school elliptics
-2.10
256 * Thu Aug
30 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.3
257 - Added python
-support to dep list
258 - Use correct package name
in shlibs
260 * Wed Aug
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.2
261 - Switch to cmake from autoconf
263 * Mon Aug
20 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.17.0.1
264 - Depend on eblob
0.17.1 and higher
265 - Use log level instead of log mask
266 - Depend on smack
0.5.0 and higher
268 - Added
in-memory
(optionally disk
-backed
) LRU cache
269 - Get rid of boost
-filesystem
270 - Split code
(and debian package
) to client
/server libs
271 - New unlink interfaces
272 - Added ioflags to ioclient
273 - If lookup returned error
, proceed
read-latest with default order
274 - Let DNET_CMD_DEL use dnet_io_attr structure too
276 * Wed Aug
08 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.16.0.1
277 - Added possibility to start defragmentation on demand
278 - Added reserved 'hostname' word
for local address
279 - Added cleanup call into node destruction path
, which fixes double free error
in config error path
280 - Implemented blocking
exec commands
281 - Refactor pools of workers
282 - Set cocaine log level based on elliptics log mask
283 - Completely created client library
284 - Fixed json example path
286 * Tue Jul
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.15.0.1
287 - Send correct answer
in smack_write
289 - New event string
for application invocation
290 - Corrected changelog
291 - Depend on smack
0.4.0 and higher
293 * Mon Jul
02 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.4
294 - Log all client job errorrs into app
/.log file
in elliptics
295 - Set nocsum flags
in io
-attr when it is
set in global node's config
297 * Wed Jun
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.3-1
298 - Depend on smack
0.3.0 and higher
300 * Tue Jun
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.2-1
301 - Use smack_total_elements
() to get number of records
303 * Mon Jun
25 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.1.1-1
304 - Disable signals
in library and
enable in server and ioclient
305 - Added cocaine library documentation
306 - Added smack configuration
307 - Sync with upstream smack repo
309 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.7-1
310 - Fixed typo
in smack config parser
312 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.6-1
313 - Sink srw log into app
+ ".log" object
in elliptics
315 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.5-1
316 - Added SMACK backend depends
318 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.4-1
319 - Drop cocaine plugin dependencies
321 * Fri Jun
22 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.3-1
322 - Added new cocaine debian package deps
323 - Drop cocaine deps
in RHEL
/Fedora build
325 * Thu Jun
21 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.2-1
326 - Build srw fix
(use weak symbol
for dnet_log_raw
())
327 - Added new eblob bit to config documentation
, drop unused parameters
328 - Fixed write response generation
330 * Fri Jun
15 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.14.0.1-1
331 - Use cocaine workers
for server
-side
332 - Drop dnet_attr structure
333 - Optimize
read (do not send ack
if there is data
)
334 - Use ioremap
::elliptics namespace
335 - Added
::push
() - nonblocking
exec
337 * Sun Apr
28 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.9-1
338 - Do not allow zero
-sized reads
339 - Do not double
-close python init file
341 * Sat Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.8-1
342 - Added new lookup
() methods to c
++/python bindings.
Patch by Anton Kortunov
<toshik@yandex
-team.ru
>
343 - If we fail to open log file
, dup2
() stdout
/stderr to
/dev
/null
in spawned worker process
345 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.7-1
346 - More mess with
012 file descriptors
- dup them to
/dev
/null when going background
, reopen to log file
in srw worker
347 - Use correct F_SETFD
/FD_CLOEXEC
348 - Use old
-school fcntl
() instead of accept4
() and epoll_create1
()
349 - Allow script execution without cmd
-line
351 * Fri Apr
27 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.6-1
352 - Added srw config options
353 - Added O_CLOEXEC flags
354 - Added new configs
(for nginx and fastcgi frontend
) and python example
355 - Return sub data from smack_write
() call
- this is needed
for fastcgi frontend
356 - Let dnet_ioclient write file by ID
357 - Added smack backend wrapper
359 * Fri Apr
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.5-1
360 - Build dependencies update
361 - Do not write metadata when appropirate bit is
set in node
->flags
362 - Update documentation about blob flags
364 * Fri Mar
23 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.4-1
365 - Updated state mixing algorithm
366 - Added defrag_timeout
, defrag_percentage and blob_size options to file backend
368 * Mon Mar
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.3-1
369 - Allow ioclient to
read/write data
in different columns
370 - Hardlink script should overwrite data
371 - Fixed file
read/write with different column
372 - Use correct pipe path
, which includes pid
373 - Use correct structure size
for dentries and extended logging
374 - Do not
set name
for main process
376 * Sun Mar
13 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.2-1
377 - Use exactly specified
in config socket family
378 - Obsolete srw by ellipitcs
379 - Revert "Use X bits from operation key to find a lock instead of random hashing"
380 - Added proper sigchild handling
381 - spec update
- added libsrw.so
* files
382 - Dropped srw dependancy
384 * Sun Mar
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.13.0.1-1
387 * Wed Feb
29 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.12.0.1-1
388 - Depend on
0.15 eblob
: added new defragmentation parameters into config
389 - Propagate prepare_write
() and friends
return values back to callers
- changed API
391 * Sun Feb
19 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.7-1
392 - Get rid of virtually unused and unneded eblob generation tools. It can be replaced by trivial python scripts
393 - Updated python scripts to use new eblob class
394 - exec is reserved name
in python
, use exec_script
for execution method name
396 * Thu Feb
16 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.6-1
397 - Added possibility to
read metadata from file and dump to log
398 - Added remove_keys_from_storage_found_removed_in_eblob.py
399 - Added
local merge iterator written
in python. Is not optimal
, but quite fast.
401 * Tue Feb
14 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.5-1
402 - Execute CHECK commands with NOLOCK flag
404 * Sat Feb
11 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.4-1
405 - Use correct eblob path
for statvfs
() request
407 * Mon Feb
8 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.3-1
408 - Set id.
type to
0 where appropriate
409 - Request statistics with DNET_ATTR_NOLOCK flag
set
410 - Fixed pohmelfs_rename.py
412 * Mon Feb
6 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.2-1
413 - Process checksum flags according to aflags and ioflags
415 * Wed Feb
1 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.1.1-1
416 - Added start
/num parameters to iterate over selected number of blobs.
417 - Depend on
0.14.1 blob and higher where it is implemented.
419 * Thu Jan
26 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.15-1
420 - Added readdir script
421 - Dropped content length manipulation from srw
/pohmelfs_inode_info_insert.py
422 - Use dnet_process_meta instead of dnet_process_cmd_raw to prevent deadlocks
424 * Tue Jan
24 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.14-1
425 - Reserve some space
for directory content
426 - Added pohmelfs_read_latest_groups.py script
427 - Implemented prepare
-latest helper
, which returns timestamp sorted groups which contain requested id
428 - If we have more data to send
, set only DNET_FLAGS_MORE flag
, not erase others
429 - Rename cpp bindings
430 - Fixed range requests without limits
432 * Tue Jan
17 2012 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.13-1
433 - Sort keys on server side
in range requests
434 - Disable eblob_gen
for now
435 - Address new binutils issues
(gcc
4.6 compilation fixes
)
437 * Wed Dec
21 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.12-1
438 - Trying to address new binutils issues
439 - Fill with zeroes all io threads structures
440 - Set io.num to content size
+offset
in write_data_wait
() - it allows to use prepare
/commit flags
442 * Tue Dec
20 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.11-1
443 - Implemented check
for start
/stop update timestamp
444 - Added cache tests
in test.cpp
446 * Thu Dec
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.10-1
447 - Added configurable two
-queue cache
for read data by Anton Kortunov
<toshic.toshic@gmail.com
>
449 * Mon Dec
12 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.9-1
450 - Reopen log file on sighup
452 * Fri Dec
9 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.8-1
453 - Set DNET_FLAGS_NOLOCK
for route
/reverse lookup request
/reply commands
454 - Added memory_test_pohmelfs
() autotest
455 - Added gc calls into pohmelfs methods
456 - Fixed exception string generation
for null ids
457 - Added small memory
/leak
test
459 * Fri Dec
2 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.7-1
460 - Use eblob_read_nocsum
() if DNET_IO_FLAGS_NOCSUM is
set
462 * Thu Dec
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.6-1
463 - Cleanup unused variables
464 - Fixed reply cmd
->flags initialization
465 - Use boost
::filesystem v2
466 - Fixes
in bulk_read and bulk_write
468 * Mon Nov
28 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.5-1
469 - Implemented pool of non
-blocking threads
for recursive commands.
470 - Dropped metadata csum support
in favour of eblob embedded checksums.
471 - Added bulk_write operation.
472 - Added sstable parser into python module
474 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.4-1
475 - Added nolocking IO thread
477 * Thu Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.3-1
478 - Added oplock_num config parameter
479 - Added non
-blocking thread checks
481 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.2-1
482 - Aflags
/lock cleanups
484 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.11.0.1-1
485 - Added operations locks. Now all commands are processed with single
-machine
-atomicity
486 - Added server
-side scripts
488 * Wed Nov
23 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.13-1
489 - Only perform blob write
if io
->size is not zero
491 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.12-1
492 - Initialize srw after node
494 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.11-1
495 - Do not chroot into
history environment
, since it is most likely incomplete
497 * Tue Nov
22 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.10-1
498 - Do not csum
read when DNET_IO_FLAGS_NOCSUM ioflag is
set
499 - When doing partial
read, checksum whole file
501 * Sat Nov
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.9-1
503 - Return
-ENOTSUP
if srw is not initialized
504 - Do not reset join state to RECONNECT after it has been created
505 - Added stall_count as a configurable parameter
506 - Added BULK_READ
command
508 * Tue Nov
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.8-1
509 - Fixed range counters
510 - Added
::remove
() methods into python binding
511 - Remove all types
if -1 as id
->type is specified
512 - RHEL build must depend on eblob
-devel
>= 0.12.18 libsrw
-devel
>= 0.2.2
514 * Mon Nov
14 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.7-1
515 - Moved some objects from interface.h to packet.h
516 - Added range counters
517 - DNET_IO_FLAGS_PLAIN_WRITE must differ from DNET_IO_FLAGS_NOCSUM
518 - Use IP_TOS instead of SO_PRIORITY to
set tos bits
519 - srw is called libsrw
in rhel builds
520 - Depend on
0.12.18 eblob and
0.2.2 srw
522 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.6-1
523 - Depend on
0.2.1 srw and higher
525 * Thu Nov
3 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.5-1
526 - Added binary data support
in srw
528 * Tue Nov
1 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.4-1
529 - Do not fail node initialization
if srw is not initialized
531 * Mon Oct
31 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.3-1
532 - blob_send modified to send all columns
if id.
type == -1
533 - Do not depend elliptics build on libssl
534 - eblob
/srw autoconf updates
535 - Do not
return 1 from blob_write when data was compressed
, return 0, since
538 * Tue Oct
25 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.2-1
539 - Added srw dependency
540 - Do not call dnet_convert_io_attr
for DNET_CMD_DEL
command
542 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.1-1
543 - Decreased WRITE latency
544 - Use CORK
for write blocks
546 * Wed Oct
19 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.4.0-1
547 - Added ioprio call inside check
548 - More example ioserv.conf comments
549 - Added client
/server network priorities
(man
7 socket
-> IP_PRIORITY
)
551 * Sat Oct
15 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.9-1
552 - Fixed memory allocation
in range
-delete
554 * Tue Oct
11 2011 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.10.3.7-1
555 - Only
set BLOB_DISK_CTL_NOCSUM
if DNET_IO_FLAGS_NOCSUM is
set
556 - Added dnet_get_routes
function
557 - Added server
-side scripting support
558 - Example ioserv.conf update
561 * Thu Dec
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.2-1
562 - Implemented multiple
read in elliptics core and FCGI frontend.
563 - Implemented very user
-friendly C
++/Python interface.
564 - Extended FCGI xml output
for POST request
: added data crc
, size
,
565 per
-group addresses and path to the destination object on file backend.
567 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.5.1-1
568 - Documentation update.
570 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.8-1
571 - Fixed fcgi reading with new groups URI.
573 * Fri Dec
3 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.7-1
574 - Implemented automatic groups selection by free space.
577 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.6-1
578 - Fixed eblob_send
().
579 - Use
50 check threads.
581 * Thu Dec
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.5-1
582 - Multi
-threaded fsck.
583 - Bug fixes
(including
2.9.4.4 version
).
585 * Thu Nov
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.3-1
586 - Implemented bdb fsck
(both merge and copy check
).
588 * Thu Nov
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.2-1
589 - Switched to random ids
(1024 ids are generated at first start
)
591 * Fri Nov
19 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.4.1-1
592 - Switched to new addressing model
594 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.14-1
595 - Remove direct object
if it can not be uploaded to the storage.
597 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.13-1
598 - Remove empty
/broken
history objects during merge.
600 * Tue Nov
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.12-1
601 - Added more debug about processed objects
in fsck tools.
602 - Delete directly
read object
if its
history can not be mapped.
603 - Return error from dnet_merge_direct
() when merge falls back to direct
604 merge during common merge.
606 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.11-1
607 - Attempt to
do direct merge when we can not parse non
-direct
history stored
in main storage.
609 * Sat Nov
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.10-1
610 - Fixed bit directory generation
in file_backend_get_dir_bits
()
612 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.9-1
613 - Fixed state leak
in lookup processing.
615 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.8-1
616 - Always use
local address
for succeeded
local lookup.
618 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.7-1
619 - Kill state when check thread got error.
(7)
620 - Extended fire
time debug.
(6)
622 * Thu Oct
21 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.5-1
623 - Update transaction fire
time to include check timeout.
625 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.4-1
626 - Extend dnet_send_read_data
() to get offset from parameters and
do not abuse dnet_io_attr structure.
628 * Wed Oct
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.3-1
629 - Unmap
history after selecting transaction with the last update
time in dnet_merge_get_latest_transactions
()
631 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
632 - Added full object ID dump and request error.
633 - Exit merge early
if no id file was provided.
634 - Do not dereference state
in dnet_read_complete
() if it is NULL.
635 - Added
-N
(do not request ids and use prevously downloaded
) option comment into fsck
help.
637 * Mon Oct
18 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3.2-1
638 - Extended alloc
/free debug.
639 - Allow zero
-sized writes.
641 * Wed Oct
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.3-1
642 - New minor release. No changes from
2.9.2.32.
644 * Mon Oct
11 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.32-1
645 - Added configurable value to check header
for remote node IP address.
646 - Added joining client check
: returned address must be reachable to be
647 inserted into route table.
649 * Fri Oct
8 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.31-1
652 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.29-1
653 - Added id
-by
-LA generation and sorting.
656 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.28-1
657 - Added timed statistics request which also works as timed connection checker.
658 - Added seconds
-only check
time wait.
660 * Wed Oct
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.27-1
661 - Added keep
-alive options.
663 * Mon Oct
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.26-1
664 - Unlink transaction and
history after direct merge.
665 - Do not log error when state is NULL
in completion callback.
667 * Sat Oct
2 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.25-1
668 - Added norequest flag to fsck util
(will use existing file
).
669 - Fixed remotes processing typo.
671 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.24-1
672 - Do not traverse the whole transaction tree after we found the
673 first one which fire
time has not yet elapsed.
675 * Thu Sep
30 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.23-1
676 - Remove io_thread_num and max_pending config parameters.
677 - Added stack size parameter to check tools.
679 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.22-1
680 - Moved transaction debug output into the place where it can not dereference stale data.
681 - Decrease debug level
for allocations.
682 - Added addrinfo null check. Should be useless though.
684 * Mon Sep
20 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.21-1
685 - Do not dereference null state
in dnet_fcgi_read_complete.
687 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.20-1
688 - Added thread stack size parameter.
689 - Added malloc mmap threshold config parameter.
(19)
691 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.18-1
692 - Really fixed recv state transaction processing leak.
694 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.16-1
695 -Do not try to dereferece null state. Happens when transaction is completed
697 - Use lineary
(+60 seconds each turn
) growing reconnection timeout. Added
698 reconnection limit of
1 day.
699 - Fixed recv state transaction processing leak.
701 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.15-1
702 - Compilation typo fixed.
704 * Fri Sep
17 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.14-1
705 - Fill all allocated memory with zeroes.
707 * Thu Sep
16 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.13-1
708 - Put transaction after it was executed. Its refcnt was increased during
710 - Do not try to dereference state when it can be null.
711 - Do not create unneded listening state when node does not join network.
(12)
712 - Reset accept state on error.
713 - Do not join to states
in state lists
, since they can be freed
in own
715 - Drop transaction resending support.
(10)
716 - Extended
local command processing log.
(9)
717 - Also print pid
in common logger.
(8)
718 - Use pthread_self
() instead of getpid
() to get uniq thread id.
(7)
720 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2.6-1
721 - If DNET_IO_FLAGS_NO_HISTORY_UPDATE flag was
set for read command, do not
722 send data reply. Used
in local stat
command.
724 - From previous releases
:
725 Do not deal with NULL transactions.
726 Start state IO thread after state initialization.
727 Join to io state thread instead of freeing it directly.
728 Do not
exit from accept loop on error.
729 Initialize state list entry prior other usage.
731 * Tue Sep
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.2-1
732 - Switched from libevent state machine to thread
-per
-client model.
734 * Fri Aug
13 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1.1-1
735 - Added DNET_FCGI_PUT_REGION config option to optionally
enable region tag
736 - Added wildcard direct download pattern
(*)
737 - Force direct download patterns to be checked against ID ending and
738 just by having this substring somewhere
in the query.
740 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.1-1
741 - New elliptics network release
: 2.9.1
743 * Tue Aug
10 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.31-1
745 - Fixed resend locking bug.
747 * Mon Aug
9 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.30-1
748 - Fixed lock
/unlock typo
in dnet_data_ready
().
750 * Sat Aug
7 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.29-1
751 - Refactor fcgi logging
(29)
752 - Return
read error when key was not found. Use right config file options.
(28)
754 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.27-1
755 - Added sanity checks
for embedded reading.
757 * Thu Aug
6 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.26-1
758 - Disabled per
-client statistics request
in fcgi daemon.
759 - Added subtle timeout and data rewrite when FCGX_PutStr
() returns error.
761 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.25-1
762 - Copy resolved address into buffer
(later used
for reconnection
)
763 before trying to connect.
765 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.24-1
766 - Refactor fcgi
/check loggers to write pid
/thread id into single log file.
768 * Thu Aug
5 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.23-1
769 - Added
<region
> tag into download
-info XML output
770 - Changed sending locking.
772 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.22-1
773 - Guard multiple 'logical' xml writes against parallel write
775 * Wed Aug
4 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.21-1
776 - Implemented direct transaction merge.
777 - If reading size was
set to
0 map ~
0ULL size
, i.e. the whole file.
778 - Remove object from the storage
if its
history log says so.
779 - Drop unused DNET_FCGI_EMBED_TIMESTAMP_PATTERN and change to use
780 DNET_FCGI_EMBED_PATTERN option.
782 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.20-1
783 - Fixed several fd leaks.
785 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.19-1
786 - Unmap
history file when failed to
read transaction.
788 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.18-1
789 - Guard OpenSSL_add_all_digests
() and initialize it only once per thread
791 - Force dnet_check_process_request
() to
wait for all sent transactions
, do
792 not wakeup after receiving reply from the first one.
794 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.17-1
795 - Fixed compilation warnings on
64bit platform
(uint64_t to unsigned long
796 long and void
* to unsigned long
)
797 - Try only requested transformation
function, do not
continue with the next
799 - Use errno to differentiate reconnection state.
801 * Sun Jul
28 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.15-1
802 - Made elliptics depend on eblob
803 - Updated checker's logger.
804 - Increase example
/check
/common.c waiting timeout.
805 - Added logs into file io backend listing processor.
807 * Sun Jul
26 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.12-1
808 - Let check applications to sleep longer waiting
for replies.
809 - Reduce number of ids sent via DNET_CMD_LIST
command to
1024 per reply.
810 - Mark states added via dnet_add_state
() as reconnect
-friendly.
811 - Do not add reconnection addresses which
do not have joining flags.
812 - Updated to the latest eblob lib
(moved blob code outside to libeblob
).
813 - Reschedule transaction's fire
time when
(non
-last
) reply is received.
814 - Do not mess with dnet_fcgi_random_hashes outside of fcgi.c
816 * Sun Jul
25 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.11-1
817 - Added embedded URI parameter
, which will force timestamp to be embedded
818 with data. It is possible to embed other parameters too.
820 post
: wget
-O
/tmp
/1111 -S
--post
-file
=elliptics.spec
821 "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
×tamp
=123"
823 get
: wget
-O
/tmp
/1111 -S
--header
="If
-Modified
-Since
: Thu
, 01 Jan
1970
824 00:02:00 GMT" "http
://devfs1
/test.mp3?name
=qwerty.xml
&embed
&direct
=1"
825 - fixed random
hash selection
in fcgi frontend.
827 * Fri Jul
23 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.10-1
828 -return back addressing magic^W logic
in dnet_write_object_raw
()
830 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.9-1
831 - return back virtual datacenters.
833 * Thu Jul
22 2010 Evgeniy Polyakov
<zbr@ioremap.net
> - 2.9.0.8-1
834 - BLOB IO backend updates
(multiple threads
, index
, bug fixes
).
835 - file IO backend fixes
839 * Mon Jul
19 2010 Arkady L. Shane
<ashejn@yandex
-team.ru
> - 2.9.0.7-1
840 - initial build
for Fedora