1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for ParaView-3.14.1
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
65 %define version
3.14.1
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.paraview.org
/files
/v3.14
/
76 Source: %url/%{name}-%{version}-Source.tar.gz
78 Group: Development
/Tools
79 Patch0: ParaView
-3.14.1.patch_0_ParaView.git_0f43430
80 Patch1: ParaView
-3.14.1.patch_1
81 Patch2: ParaView
-3.14.1.patch_2
82 Patch3: ParaView
-3.14.1.patch_darwin
84 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
86 #--------------------------------------------------------------------------
88 # Here, we define default compiling options for cmake
90 # One can override the option on the commande line : --define='MACRO EXPR'
92 %{!?_withVerbose: %define _withVerbose false}
93 %{!?_withMesa: %define _withMesa false}
94 %{!?_withMPI: %define _withMPI false}
95 %{!?_withPython: %define _withPython false}
96 %{!?_withQt: %define _withQt true}
97 %{!?_qmakePath: %define _qmakePath Undefined}
98 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
99 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
100 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
102 #--------------------------------------------------------------------------
108 %setup -q
-n ParaView
-3.14.1-Source
110 # Patch from ParaView.git
111 # BUG #13065. CMake files were not being installed correctly.
114 # Correction to BUG #13065.
117 # Correction to BUG #13101.
121 # Patch for proper install of paraview binary under Mac OS X
127 # set CMake cache variables
133 CMAKE_VARIABLES
="$CMAKE_VARIABLES
-D$
1"
138 # export WM settings in a form that GNU configure recognizes
139 [ -n "$WM_CC"
] && export CC
="$WM_CC"
140 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
141 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
142 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
143 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
147 echo "Compilation options
:"
148 echo " _withVerbose
: %{_withVerbose}"
149 echo " _withMesa
: %{_withMesa}"
150 echo " _withMPI
: %{_withMPI}"
151 echo " _withPython
: %{_withPython}"
152 echo " _withQt
: %{_withQt}"
153 echo " _qmakePath
: %{_qmakePath}"
154 echo " _mesaIncludePath
: %{_mesaIncludePath}"
155 echo " _mesaLibPath
: %{_mesaLibPath}"
156 echo " _pythonLibPath
: %{_pythonLibPath}"
160 # start with these general settings
161 addCMakeVariable VTK_USE_TK
:BOOL
=OFF
162 addCMakeVariable PARAVIEW_ENABLE_PYTHON
:BOOL
=ON
163 addCMakeVariable PARAVIEW_USE_MPI
:BOOL
=ON
164 addCMakeVariable BUILD_SHARED_LIBS
:BOOL
=ON
165 addCMakeVariable CMAKE_BUILD_TYPE
:STRING
=Release
167 # include development files in "make install"
168 addCMakeVariable PARAVIEW_INSTALL_DEVELOPMENT
:BOOL
=ON
171 # Additional installation rules for Mac OS X
172 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE
:FILEPATH
=%{_topdir}/BUILD/%{name}-%{version}-Source/Applications
/ParaView
-3.14.1_extra_install_Darwin.cmake
175 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
176 addCMakeVariable QT_QMAKE_EXECUTABLE
:FILEPATH
=%{_qmakePath}
178 echo "CMAKE_VARIABLES
: $CMAKE_VARIABLES"
182 # The configuration of Paraview will be using the environment variable MACOSX_DEPLOYMENT_TARGET.
183 # This variable was initialized using 'sw_vers -productVersion' in etc/bashrc.
184 # We need to get rid of the revision number from this string. eg turn "10.7.5" into "10.7"
185 v
=( $
{MACOSX_DEPLOYMENT_TARGET
//.
/ } )
186 export MACOSX_DEPLOYMENT_TARGET
="$
{v
[0]}.$
{v
[1]}"
187 echo "Resetting MACOSX_DEPLOYMENT_TARGET to $
{MACOSX_DEPLOYMENT_TARGET
}"
194 -DCMAKE_INSTALL_PREFIX
:PATH
=%{_installPrefix} \
198 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
199 make -j $WM_NCOMPPROCS
202 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
203 # created during installation.
204 # Qt version 4.6.3 will generate some unreferenced symlinks when
205 # ParaView is compiled and installed. By enabling the following
206 # environment variable, the command brp-symlink will still complain
207 # about missing link targets, but it won't stop rpmbuild from generating
209 # For all other Unix distros, this is a no-op.
210 export NO_BRP_STALE_LINK_ERROR
=yes
213 make install DESTDIR
=$RPM_BUILD_ROOT
215 # Creation of foam-extend specific .csh and .sh files"
218 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
221 # Generate package specific .sh file for foam-extend
223 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
224 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
225 # Load %{name}-%{version} libraries and binaries if available
226 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
228 export PARAVIEW_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
229 export PARAVIEW_BIN_DIR
=\$PARAVIEW_DIR
/bin
230 export PARAVIEW_LIB_DIR
=\$PARAVIEW_DIR
/lib
231 export PARAVIEW_INCLUDE_DIR
=\$PARAVIEW_DIR
/include
/paraview
-3.14
233 export PARAVIEW_VERSION
=%{version}
235 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
236 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
237 # specified directory to see if a given library is a paraview plugin.
238 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
239 # startup of paraview or even make paraview crash on startup.
240 export PV_PLUGIN_PATH
=\$FOAM_LIBBIN
/paraview_plugins
242 [ -d \$PARAVIEW_LIB_DIR
/paraview
-3.14 ] && _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-3.14
244 # Enable access to the package applications if present
245 [ -d \$PARAVIEW_BIN_DIR
] && _foamAddPath \$PARAVIEW_BIN_DIR
247 # Additional binary path if running on Mac OS X
248 [ -d \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
] && _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
253 # Generate package specific .csh file for foam-extend
255 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
256 # Load %{name}-%{version} libraries and binaries if available
257 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
258 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
259 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR
/bin
260 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR
/lib
261 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR
/include
/paraview
-3.14
263 setenv PARAVIEW_VERSION
%{version}
265 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
266 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
267 # specified directory to see if a given library is a paraview plugin.
268 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
269 # startup of paraview or even make paraview crash on startup.
270 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN
/paraview_plugins
272 if ( -e \$PARAVIEW_BIN_DIR
) then
273 _foamAddPath \$PARAVIEW_BIN_DIR
276 if ( -e \$PARAVIEW_LIB_DIR
/paraview
-3.14 ) then
277 _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-3.14
281 # Additional binary path if running on Mac OS X
282 if ( -e \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
) then
283 _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
287 #finally, generate a .tgz file for systems where using rpm for installing packages
288 # as a non-root user might be a problem.
289 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
291 # Make sure we clean the installation directory. Somehow, make install generates files there. Need to revisit this eventually.
292 (rm -rf
%{_prefix}/packages/%{name}-%{version} )
295 rm -rf $RPM_BUILD_ROOT
296 rm -rf
%{_prefix}/packages/%{name}-%{version}
299 %defattr(-,root
,root
)