Release note export to HTML/TXT
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / ParaView-4.0.1.spec
blobaec695bca6f23617921bce3be3ee85d3d58b0211
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for ParaView-4.0.1
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Authors:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
32 # Andreas Feymark, Chalmers University of Technology, (2013)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package %{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath %{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in this file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
60 # regenerate the RPM.
62 %define _prefix %{_WM_THIRD_PARTY_DIR}
64 %define name ParaView
65 %define release %{_WM_OPTIONS}
66 %define version 4.0.1
68 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
71 Summary: ParaView
72 License: Unkown
73 Name: %{name}
74 Version: %{version}
75 Release: %{release}
76 URL: http://www.paraview.org/files/v4.0/
77 Source: %url/%{name}-v%{version}-source.tgz
78 Prefix: %{_prefix}
79 Group: Development/Tools
80 Patch0: ParaView-4.0.1.patch_darwin
82 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
84 #--------------------------------------------------------------------------
86 # Here, we define default compiling options for cmake
88 # One can override the option on the commande line : --define='MACRO EXPR'
90 %{!?_withVerbose: %define _withVerbose false}
91 %{!?_withMesa: %define _withMesa false}
92 %{!?_withMPI: %define _withMPI false}
93 %{!?_withPython: %define _withPython false}
94 %{!?_withQt: %define _withQt true}
95 %{!?_qmakePath: %define _qmakePath Undefined}
96 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
97 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
98 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
100 #--------------------------------------------------------------------------
102 %description
103 %{summary}
105 %prep
106 %setup -q -n %{name}-v%{version}-source
108 %ifos darwin
109 %patch0 -p1
110 %endif
112 %build
114 # set CMake cache variables
116 addCMakeVariable()
118 while [ -n "$1" ]
120 CMAKE_VARIABLES="$CMAKE_VARIABLES -D$1"
121 shift
122 done
125 # export WM settings in a form that GNU configure recognizes
126 [ -n "$WM_CC" ] && export CC="$WM_CC"
127 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
128 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
129 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
130 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
132 set +x
133 echo ""
134 echo "Compilation options:"
135 echo " _withVerbose : %{_withVerbose}"
136 echo " _withMesa : %{_withMesa}"
137 echo " _withMPI : %{_withMPI}"
138 echo " _withPython : %{_withPython}"
139 echo " _withQt : %{_withQt}"
140 echo " _qmakePath : %{_qmakePath}"
141 echo " _mesaIncludePath : %{_mesaIncludePath}"
142 echo " _mesaLibPath : %{_mesaLibPath}"
143 echo " _pythonLibPath : %{_pythonLibPath}"
144 echo ""
145 set -x
147 # start with these general settings
148 addCMakeVariable VTK_USE_TK:BOOL=OFF
149 addCMakeVariable BUILD_SHARED_LIBS:BOOL=ON VTK_USE_RPATH:BOOL=OFF
150 addCMakeVariable CMAKE_BUILD_TYPE:STRING=Release
152 # include development files in "make install"
153 addCMakeVariable PARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON
155 # new alternative to "make HTMLDocumentation"
156 addCMakeVariable PARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON
158 %ifos darwin
159 # Additional installation rules for Mac OS X
160 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE:FILEPATH=%{_topdir}/BUILD/%{name}-%{version}/Applications/ParaView-3.8.1_extra_install_Darwin.cmake
161 %endif
163 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
164 addCMakeVariable QT_QMAKE_EXECUTABLE:FILEPATH=%{_qmakePath}
166 echo "CMAKE_VARIABLES: $CMAKE_VARIABLES"
168 mkdir -p ./buildObj
169 cd ./buildObj
171 cmake \
172 -DCMAKE_INSTALL_PREFIX:PATH=%{_installPrefix} \
173 $CMAKE_VARIABLES \
176 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
177 make -j $WM_NCOMPPROCS
179 %install
180 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
181 # created during installation.
182 # Qt version 4.6.3 will generate some unreferenced symlinks when
183 # ParaView is compiled and installed. By enabling the following
184 # environment variable, the command brp-symlink will still complain
185 # about missing link targets, but it won't stop rpmbuild from generating
186 # the final rpm.
187 # For all other Unix distros, this is a no-op.
188 export NO_BRP_STALE_LINK_ERROR=yes
190 cd buildObj
191 make install DESTDIR=$RPM_BUILD_ROOT
193 # Creation of foam-extend specific .csh and .sh files"
195 echo ""
196 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
197 echo ""
199 # Generate package specific .sh file for foam-extend
201 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
202 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
203 # Load %{name}-%{version} libraries and binaries if available
204 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
206 export PARAVIEW_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
207 export PARAVIEW_BIN_DIR=\$PARAVIEW_DIR/bin
208 export PARAVIEW_LIB_DIR=\$PARAVIEW_DIR/lib
209 export PARAVIEW_INCLUDE_DIR=\$PARAVIEW_DIR/include/paraview-4.0
211 export PARAVIEW_VERSION=%{version}
213 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
214 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
215 # specified directory to see if a given library is a paraview plugin.
216 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
217 # startup of paraview or even make paraview crash on startup.
218 export PV_PLUGIN_PATH=\$FOAM_LIBBIN/paraview_plugins
220 [ -d \$PARAVIEW_LIB_DIR/paraview-4.0 ] && _foamAddLib \$PARAVIEW_LIB_DIR/paraview-4.0
222 # Enable access to the package applications if present
223 [ -d \$PARAVIEW_BIN_DIR ] && _foamAddPath \$PARAVIEW_BIN_DIR
225 # Additional binary path if running on Mac OS X
226 [ -d \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS ] && _foamAddPath \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS
228 DOT_SH_EOF
231 # Generate package specific .csh file for foam-extend
233 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
234 # Load %{name}-%{version} libraries and binaries if available
235 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
236 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
237 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR/bin
238 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR/lib
239 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR/include/paraview-4.0
241 setenv PARAVIEW_VERSION %{version}
243 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
244 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
245 # specified directory to see if a given library is a paraview plugin.
246 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
247 # startup of paraview or even make paraview crash on startup.
248 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN/paraview_plugins
250 if ( -e \$PARAVIEW_BIN_DIR ) then
251 _foamAddPath \$PARAVIEW_BIN_DIR
252 endif
254 if ( -e \$PARAVIEW_LIB_DIR/paraview-4.0 ) then
255 _foamAddLib \$PARAVIEW_LIB_DIR/paraview-4.0
256 endif
259 # Additional binary path if running on Mac OS X
260 if ( -e \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS ) then
261 _foamAddPath \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS
262 endif
263 DOT_CSH_EOF
265 #finally, generate a .tgz file for systems where using rpm for installing packages
266 # as a non-root user might be a problem.
267 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
269 %clean
271 %files
272 %defattr(-,root,root)
273 %{_installPrefix}