1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for PyFoam-0.6.3
28 # RPM spec file for PyFoam version 0.6.3
31 # Martin Beaudoin, Hydro-Quebec, (2013)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
76 URL: http
://openfoamwiki.net
/images
/e
/e3
/PyFoam
-0.6.3-rc.tar.gz
77 Source: %url/%{name}-%{version}-rc.tar.gz
79 Group: Development
/Tools
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms
/noarch
87 %setup -q
-n PyFoam
-%{version}-rc
90 # Make the shebang line portable
91 python setup.py build
--executable "
/usr
/bin
/env python"
94 python setup.py
install --prefix
=$RPM_BUILD_ROOT
/%{_installPrefix}
96 %define pythonVersion $
(python
-V
2>&1 | awk
-F ' '
{'print $
2'
} | awk
-F \.
{'print $
1 "." $
2'
})
98 # Creation of foam-extend specific .csh and .sh files"
101 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
104 # Generate package specific .sh file for foam-extend
106 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
107 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
108 # Load %{name}-%{version} libraries and binaries if available
109 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
111 export PYFOAM_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/noarch
112 export PYTHONPATH
=\$PYFOAM_DIR
/lib
/python
%{pythonVersion}/site
-packages
:\$PYTHONPATH
114 # Enable access to the package applications if present
115 [ -d \$PYFOAM_DIR
/bin
] && _foamAddPath \$PYFOAM_DIR
/bin
120 # Generate package specific .csh file for foam-extend
122 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
123 # Load %{name}-%{version} libraries and binaries if available
124 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
125 setenv PYFOAM_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/noarch
127 if ! \$?PYTHONPATH
then
128 setenv PYTHONPATH \$PYFOAM_DIR
/lib
/python
%{pythonVersion}/site
-packages
130 setenv PYTHONPATH \$PYFOAM_DIR
/lib
/python
%{pythonVersion}/site
-packages
:\$PYTHONPATH
134 if ( -e \$PYFOAM_DIR
/bin
) then
135 _foamAddPath \$PYFOAM_DIR
/bin
138 if \$?PYFOAM_SITE_DIR
then
139 if ( -e \$PYFOAM_SITE_DIR
/bin
) then
140 _foamAddPath \$PYFOAM_SITE_DIR
/bin
145 cat
<< DOT_HARDCODED_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}_hardcoded.sh
146 # In this version of the configuration script, the paths are hardcoded,
147 # which makes it easier to load PyFoam without the foam-extend environment
150 # Load %{name}-%{version} libraries and binaries if available
151 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
153 export PYFOAM_DIR
=$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/noarch
154 export PYTHONPATH
=\$PYFOAM_DIR
/lib
/python
%{pythonVersion}/site
-packages
:\$PYTHONPATH
156 # Enable access to the package applications if present
157 [ -d \$PYFOAM_DIR
/bin
] && export PATH
=\$PYFOAM_DIR
/bin
:\$PATH
162 # Generate package specific .csh file for foam-extend
164 cat
<< DOT_HARDCODED_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}_hardcoded.csh
165 # In this version of the configuration script, the paths are hardcoded,
166 # which makes it easier to load PyFoam without the foam-extend environment
169 # Load %{name}-%{version} libraries and binaries if available
170 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
171 setenv PYFOAM_DIR $WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/noarch
173 if ! \$?PYTHONPATH
then
174 setenv PYTHONPATH \$PYFOAM_DIR
/lib
/python
%{pythonVersion}/site
-packages
176 setenv PYTHONPATH \$PYFOAM_DIR
/lib
/python
%{pythonVersion}/site
-packages
:\$PYTHONPATH
180 if ( -e \$PYFOAM_DIR
/bin
) then
181 _foamAddPath \$PYFOAM_DIR
/bin
184 if \$?PYFOAM_SITE_DIR
then
185 if ( -e \$PYFOAM_SITE_DIR
/bin
) then
186 _foamAddPath \$PYFOAM_SITE_DIR
/bin
189 DOT_HARDCODED_CSH_EOF
191 #finally, generate a .tgz file for systems where using rpm for installing packages
192 # as a non-root user might be a problem.
193 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
200 %defattr(-,root
,root
)