Release note export to HTML/TXT
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / metis-5.1.0.spec
blob5450c3e68cd048ae54423d3e9be88d03e75daeed
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for metis-5.1.0
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name metis
64 %define release %{_WM_OPTIONS}
65 %define version 5.1.0
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: metis
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
79 Patch0: metis-5.1.0_patch_gcc
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 %description
84 %{summary}
86 %prep
87 %setup -q
89 %ifos linux
90 %patch0 -p1
91 %endif
93 %build
94 [ -n "$WM_CC" ] && export CC="$WM_CC"
95 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
96 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
97 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
98 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
100 [ -n "$WM_CXX" ] && export OMPI_CXX="$WM_CXX"
102 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
104 %ifos darwin
105 make config
106 # The parameter -D_POSIX_C_SOURCE=200809 has a side effect on Mac OS X
107 make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC" CC=$CC
108 %else
109 make config
110 make -j $WM_NCOMPPROCS OPTFLAGS="-O3 -fPIC -D_POSIX_C_SOURCE=200809" CC=$CC
111 %endif
113 %install
114 # Manual installation
115 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include
116 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
117 cp build/*/libmetis/libmetis.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
118 cp include/metis.h $RPM_BUILD_ROOT/%{_installPrefix}/include
120 # Creation of foam-extend specific .csh and .sh files"
122 echo ""
123 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
124 echo ""
126 # Generate package specific .sh file for foam-extend
128 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
129 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 export METIS_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
134 export METIS_BIN_DIR=\$METIS_DIR/bin
135 export METIS_LIB_DIR=\$METIS_DIR/lib
136 export METIS_INCLUDE_DIR=\$METIS_DIR/include
138 # Enable access to the package runtime applications and libraries
139 [ -d \$METIS_BIN_DIR ] && _foamAddPath \$METIS_BIN_DIR
140 [ -d \$METIS_LIB_DIR ] && _foamAddLib \$METIS_LIB_DIR
142 DOT_SH_EOF
145 # Generate package specific .csh file for foam-extend
147 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
148 # Load %{name}-%{version} libraries and binaries if available
149 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
150 setenv METIS_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
151 setenv METIS_BIN_DIR \$METIS_DIR/bin
152 setenv METIS_LIB_DIR \$METIS_DIR/lib
153 setenv METIS_INCLUDE_DIR \$METIS_DIR/include
155 if ( -e \$METIS_BIN_DIR ) then
156 _foamAddPath \$METIS_BIN_DIR
157 endif
159 if ( -e \$METIS_LIB_DIR ) then
160 _foamAddLib \$METIS_LIB_DIR
161 endif
162 DOT_CSH_EOF
164 #finally, generate a .tgz file for systems where using rpm for installing packages
165 # as a non-root user might be a problem.
166 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
169 %clean
170 rm -rf %{buildroot}
172 %Files
173 %defattr(-,root,root)
174 %{_installPrefix}/*