1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for openmpi-1.4.3
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.open
-mpi.org
/software
/ompi
/v1.4
/downloads
76 Source: %url/%{name}-%{version}.tar.gz
78 Group: Development
/Tools
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
91 # export WM settings in a form that GNU configure recognizes
92 [ -n "$WM_CC"
] && export CC
="$WM_CC"
93 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
94 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
95 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
96 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
99 # Enable GridEngine if it appears to be in use
100 # If you don't want any integration with SGE, simply unset the SGE
101 # environment variable
102 if [ -n "$SGE_ROOT"
]
104 mpiWith
="$mpiWith
--with
-sge"
106 mpiWith
="$mpiWith
--without
-sge"
107 mpiWith
="$mpiWith
--enable-mca
-no
-build
=ras
-gridengine
,pls
-gridengine"
111 # Adjust according to your local paths
112 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
114 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
115 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
119 --prefix
=%{_installPrefix} \
120 --exec_prefix
=%{_installPrefix} \
121 --disable
-mpirun
-prefix
-by
-default \
122 --disable
-orterun
-prefix
-by
-default \
123 --enable-shared
--disable
-static \
128 --disable
-mpi
-profile $mpiWith
130 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
131 make -j $WM_NCOMPPROCS
134 make install DESTDIR
=$RPM_BUILD_ROOT
136 # Creation of foam-extend specific .csh and .sh files"
139 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
142 # Generate package specific .sh file for foam-extend
144 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
145 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
146 # Load %{name}-%{version} libraries and binaries
147 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
148 export OPENMPI_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
149 export OPENMPI_BIN_DIR
=\$OPENMPI_DIR
/bin
150 export OPENMPI_LIB_DIR
=\$OPENMPI_DIR
/lib
152 # Enable access to the package runtime applications and libraries
153 [ -d \$OPENMPI_BIN_DIR
] && _foamAddPath \$OPENMPI_BIN_DIR
154 [ -d \$OPENMPI_LIB_DIR
] && _foamAddLib \$OPENMPI_LIB_DIR
156 export MPI_HOME
=\$OPENMPI_DIR
157 export MPI_ARCH_PATH
=\$MPI_HOME
158 export OPAL_PREFIX
=\$MPI_ARCH_PATH
160 # We initialize the rest of the environment using mpicc --showme:
161 export OPENMPI_INCLUDE_DIR
="\`mpicc
--showme
:incdirs\`"
162 export OPENMPI_COMPILE_FLAGS
="\`mpicc
--showme
:compile\`"
163 export OPENMPI_LINK_FLAGS
="\`mpicc
--showme
:link\`"
165 # Set the foam-extend compilation flags
166 export PINC
=\$OPENMPI_COMPILE_FLAGS
167 export PLIBS
=\$OPENMPI_LINK_FLAGS
170 if [ "\$FOAM_VERBOSE"
-a "\$PS1"
]
172 echo " Environment variables defined
for OpenMPI
:"
173 echo " OPENMPI_BIN_DIR
: \$OPENMPI_BIN_DIR"
174 echo " OPENMPI_LIB_DIR
: \$OPENMPI_LIB_DIR"
175 echo " OPENMPI_INCLUDE_DIR
: \$OPENMPI_INCLUDE_DIR"
176 echo " OPENMPI_COMPILE_FLAGS
: \$OPENMPI_COMPILE_FLAGS"
177 echo " OPENMPI_LINK_FLAGS
: \$OPENMPI_LINK_FLAGS"
179 echo " MPI_HOME
: \$MPI_HOME"
180 echo " MPI_ARCH_PATH
: \$MPI_ARCH_PATH"
181 echo " OPAL_PREFIX
: \$OPAL_PREFIX"
182 echo " PINC
: \$PINC"
183 echo " PLIBS
: \$PLIBS"
188 # Generate package specific .csh file for foam-extend
190 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
191 # Load %{name}-%{version} libraries and binaries
192 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
193 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
194 setenv OPENMPI_BIN_DIR \$OPENMPI_DIR
/bin
195 setenv OPENMPI_LIB_DIR \$OPENMPI_DIR
/lib
197 # Enable access to the package runtime applications and libraries
198 if ( -e \$OPENMPI_BIN_DIR
) then
199 _foamAddPath \$OPENMPI_BIN_DIR
202 if ( -e \$OPENMPI_LIB_DIR
) then
203 _foamAddLib \$OPENMPI_LIB_DIR
206 setenv MPI_HOME \$OPENMPI_DIR
207 setenv MPI_ARCH_PATH \$MPI_HOME
208 setenv OPAL_PREFIX \$MPI_ARCH_PATH
210 # We initialize the rest of the environment using mpicc --showme:
211 setenv OPENMPI_INCLUDE_DIR "\`mpicc
--showme
:incdirs\`"
212 setenv OPENMPI_COMPILE_FLAGS "\`mpicc
--showme
:compile\`"
213 setenv OPENMPI_LINK_FLAGS "\`mpicc
--showme
:link\`"
215 # Set the foam-extend compilation flags
216 setenv PINC "\$OPENMPI_COMPILE_FLAGS"
217 setenv PLIBS "\$OPENMPI_LINK_FLAGS"
220 if (\$?FOAM_VERBOSE
&& \$?prompt
) then
221 echo " Environment variables defined
for OpenMPI
:"
222 echo " OPENMPI_BIN_DIR
: \$OPENMPI_BIN_DIR"
223 echo " OPENMPI_LIB_DIR
: \$OPENMPI_LIB_DIR"
224 echo " OPENMPI_INCLUDE_DIR
: \$OPENMPI_INCLUDE_DIR"
225 echo " OPENMPI_COMPILE_FLAGS
: \$OPENMPI_COMPILE_FLAGS"
226 echo " OPENMPI_LINK_FLAGS
: \$OPENMPI_LINK_FLAGS"
228 echo " MPI_HOME
: \$MPI_HOME"
229 echo " MPI_ARCH_PATH
: \$MPI_ARCH_PATH"
230 echo " OPAL_PREFIX
: \$OPAL_PREFIX"
231 echo " PINC
: \$PINC"
232 echo " PLIBS
: \$PLIBS"
236 #finally, generate a .tgz file for systems where using rpm for installing packages
237 # as a non-root user might be a problem.
238 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
245 %defattr(-,root
,root
)