1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for openmpi-1.6.3
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.open
-mpi.org
/software
/ompi
/v1.6
/downloads
76 Source: %url/%{name}-%{version}.tar.gz
78 Group: Development
/Tools
81 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
91 # export WM settings in a form that GNU configure recognizes
92 [ -n "$WM_CC"
] && export CC
="$WM_CC"
93 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
94 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
95 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
96 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
99 # Enable GridEngine if it appears to be in use
100 # If you don't want any integration with SGE, simply unset the SGE
101 # environment variable
102 if [ -n "$SGE_ROOT"
]
104 mpiWith
="$mpiWith
--with
-sge"
106 mpiWith
="$mpiWith
--without
-sge"
107 mpiWith
="$mpiWith
--enable-mca
-no
-build
=ras
-gridengine
,pls
-gridengine"
111 # Adjust according to your local paths
112 # if [ -d /usr/local/ofed -a -d /usr/local/ofed/lib64 ]
114 # mpiWith="$mpiWith --with-openib=/usr/local/ofed"
115 # mpiWith="$mpiWith --with-openib-libdir=/usr/local/ofed/lib64"
119 --prefix
=%{_installPrefix} \
120 --exec_prefix
=%{_installPrefix} \
121 --enable-mpirun
-prefix
-by
-default \
122 --enable-orterun
-prefix
-by
-default \
129 --enable-mpi
-profile $mpiWith \
132 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
133 make -j $WM_NCOMPPROCS
136 make install DESTDIR
=$RPM_BUILD_ROOT
138 # Creation of foam-extend specific .csh and .sh files"
141 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
144 # Generate package specific .sh file for foam-extend
146 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
147 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
148 # Load %{name}-%{version} libraries and binaries
149 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
150 export OPENMPI_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
151 export OPENMPI_BIN_DIR
=\$OPENMPI_DIR
/bin
152 export OPENMPI_LIB_DIR
=\$OPENMPI_DIR
/lib
154 # Enable access to the package runtime applications and libraries
155 [ -d \$OPENMPI_BIN_DIR
] && _foamAddPath \$OPENMPI_BIN_DIR
156 [ -d \$OPENMPI_LIB_DIR
] && _foamAddLib \$OPENMPI_LIB_DIR
158 export MPI_HOME
=\$OPENMPI_DIR
159 export MPI_ARCH_PATH
=\$MPI_HOME
160 export OPAL_PREFIX
=\$MPI_ARCH_PATH
162 # We initialize the rest of the environment using mpicc --showme:
163 export OPENMPI_INCLUDE_DIR
="\`mpicc
--showme
:incdirs\`"
164 export OPENMPI_COMPILE_FLAGS
="\`mpicc
--showme
:compile\`"
165 export OPENMPI_LINK_FLAGS
="\`mpicc
--showme
:link\`"
167 # Set the foam-extend compilation flags
168 export PINC
=\$OPENMPI_COMPILE_FLAGS
169 export PLIBS
=\$OPENMPI_LINK_FLAGS
172 if [ "\$FOAM_VERBOSE"
-a "\$PS1"
]
174 echo " Environment variables defined
for OpenMPI
:"
175 echo " OPENMPI_BIN_DIR
: \$OPENMPI_BIN_DIR"
176 echo " OPENMPI_LIB_DIR
: \$OPENMPI_LIB_DIR"
177 echo " OPENMPI_INCLUDE_DIR
: \$OPENMPI_INCLUDE_DIR"
178 echo " OPENMPI_COMPILE_FLAGS
: \$OPENMPI_COMPILE_FLAGS"
179 echo " OPENMPI_LINK_FLAGS
: \$OPENMPI_LINK_FLAGS"
181 echo " MPI_HOME
: \$MPI_HOME"
182 echo " MPI_ARCH_PATH
: \$MPI_ARCH_PATH"
183 echo " OPAL_PREFIX
: \$OPAL_PREFIX"
184 echo " PINC
: \$PINC"
185 echo " PLIBS
: \$PLIBS"
190 # Generate package specific .csh file for foam-extend
192 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
193 # Load %{name}-%{version} libraries and binaries
194 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
195 setenv OPENMPI_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
196 setenv OPENMPI_BIN_DIR \$OPENMPI_DIR
/bin
197 setenv OPENMPI_LIB_DIR \$OPENMPI_DIR
/lib
199 # Enable access to the package runtime applications and libraries
200 if ( -e \$OPENMPI_BIN_DIR
) then
201 _foamAddPath \$OPENMPI_BIN_DIR
204 if ( -e \$OPENMPI_LIB_DIR
) then
205 _foamAddLib \$OPENMPI_LIB_DIR
208 setenv MPI_HOME \$OPENMPI_DIR
209 setenv MPI_ARCH_PATH \$MPI_HOME
210 setenv OPAL_PREFIX \$MPI_ARCH_PATH
212 # We initialize the rest of the environment using mpicc --showme:
213 setenv OPENMPI_INCLUDE_DIR "\`mpicc
--showme
:incdirs\`"
214 setenv OPENMPI_COMPILE_FLAGS "\`mpicc
--showme
:compile\`"
215 setenv OPENMPI_LINK_FLAGS "\`mpicc
--showme
:link\`"
217 # Set the foam-extend compilation flags
218 setenv PINC "\$OPENMPI_COMPILE_FLAGS"
219 setenv PLIBS "\$OPENMPI_LINK_FLAGS"
222 if (\$?FOAM_VERBOSE
&& \$?prompt
) then
223 echo " Environment variables defined
for OpenMPI
:"
224 echo " OPENMPI_BIN_DIR
: \$OPENMPI_BIN_DIR"
225 echo " OPENMPI_LIB_DIR
: \$OPENMPI_LIB_DIR"
226 echo " OPENMPI_INCLUDE_DIR
: \$OPENMPI_INCLUDE_DIR"
227 echo " OPENMPI_COMPILE_FLAGS
: \$OPENMPI_COMPILE_FLAGS"
228 echo " OPENMPI_LINK_FLAGS
: \$OPENMPI_LINK_FLAGS"
230 echo " MPI_HOME
: \$MPI_HOME"
231 echo " MPI_ARCH_PATH
: \$MPI_ARCH_PATH"
232 echo " OPAL_PREFIX
: \$OPAL_PREFIX"
233 echo " PINC
: \$PINC"
234 echo " PLIBS
: \$PLIBS"
238 #finally, generate a .tgz file for systems where using rpm for installing packages
239 # as a non-root user might be a problem.
240 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
247 %defattr(-,root
,root
)