1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for ParaView-4.1.0_Server
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2010, 2015)
32 # Andreas Feymark, Chalmers University of Technology, (2013)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 %{expand:%%define _MPI_ARCH_PATH %(echo $MPI_ARCH_PATH)}
40 %{expand:%%define _MESA_DIR %(echo $MESA_DIR)}
42 # Disable the generation of debuginfo packages
43 %define debug_package
%{nil}
45 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
46 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
47 %define _tmppath
%{_topdir}/tmp
49 # Will install the package directly $WM_THIRD_PARTY_DIR
50 # Some comments about package relocation:
51 # By using this prefix for the Prefix: parameter in this file, you will make this
52 # package relocatable.
54 # This is fine, as long as your software is itself relocatable.
56 # Simply take note that libraries built with libtool are not relocatable because the
57 # prefix we specify will be hard-coded in the library .la files.
58 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
60 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
61 # not be able to reutilize this RPM, even though it is relocatable. You will need to
64 %define _prefix
%{_WM_THIRD_PARTY_DIR}
67 %define release
%{_WM_OPTIONS}
68 %define version
4.1.0_Server
70 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
72 BuildRoot: %{buildroot}
78 URL: http
://www.paraview.org
/files
/v4.1
/
79 Source: %url/%{name}-v4.1
.0-source.tar.gz
81 Group: Development
/Tools
82 Patch0: ParaView
-v4.1
.0.patch_darwin
83 Patch1: ParaView
-v4.1
.0.patch_1
85 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
87 #--------------------------------------------------------------------------
89 # Here, we define default compiling options for cmake
91 # One can override the option on the commande line : --define='MACRO EXPR'
93 %{!?_withVerbose: %define _withVerbose false}
94 %{!?_withMesa: %define _withMesa false}
95 %{!?_withMPI: %define _withMPI false}
96 %{!?_withPython: %define _withPython false}
97 %{!?_withQt: %define _withQt true}
98 %{!?_qmakePath: %define _qmakePath Undefined}
99 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
100 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
101 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
103 #--------------------------------------------------------------------------
109 %setup -q
-n
%{name}-v4.1
.0
120 # set CMake cache variables
127 CMAKE_VARIABLES
="$CMAKE_VARIABLES
-D$
1"
132 # export WM settings in a form that GNU configure recognizes
133 [ -n "$WM_CC"
] && export CC
="$WM_CC"
134 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
135 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
136 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
137 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
141 echo "Compilation options
:"
142 echo " _withVerbose
: %{_withVerbose}"
143 echo " _withMesa
: %{_withMesa}"
144 echo " _withMPI
: %{_withMPI}"
145 echo " _withPython
: %{_withPython}"
146 echo " _withQt
: %{_withQt}"
147 echo " _qmakePath
: %{_qmakePath}"
148 echo " _mesaIncludePath
: %{_mesaIncludePath}"
149 echo " _mesaLibPath
: %{_mesaLibPath}"
150 echo " _pythonLibPath
: %{_pythonLibPath}"
154 # start with these general settings
155 addCMakeVariable BUILD_SHARED_LIBS
:BOOL
=ON
156 addCMakeVariable CMAKE_BUILD_TYPE
:STRING
=Release
157 addCMakeVariable BUILD_TESTING
:BOOL
=OFF
159 # Setings specific to ParaView server
160 addCMakeVariable PARAVIEW_USE_MPI
=ON
161 addCMakeVariable PARAVIEW_BUILD_QT_GUI
=OFF
162 addCMakeVariable VTK_USE_X
=OFF
163 addCMakeVariable OPENGL_INCLUDE_DIR
=%{_MESA_DIR}
164 addCMakeVariable OPENGL_gl_LIBRARY
=%{_MESA_DIR}/lib
/libOSMesa.so
165 addCMakeVariable VTK_OPENGL_HAS_OSMESA
=ON
167 # We build with Python. This is just too useful
168 addCMakeVariable PARAVIEW_ENABLE_PYTHON
:BOOL
=ON
171 # Additional installation rules for Mac OS X
172 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE
:FILEPATH
=%{_topdir}/BUILD/%{name}-%{version}/Applications
/ParaView
-3.8.1_extra_install_Darwin.cmake
175 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
176 addCMakeVariable QT_QMAKE_EXECUTABLE
:FILEPATH
=%{_qmakePath}
178 echo "CMAKE_VARIABLES
: $CMAKE_VARIABLES"
184 -DCMAKE_INSTALL_PREFIX
:PATH
=%{_installPrefix} \
188 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
189 make -j $WM_NCOMPPROCS
192 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
193 # created during installation.
194 # Qt version 4.6.3 will generate some unreferenced symlinks when
195 # ParaView is compiled and installed. By enabling the following
196 # environment variable, the command brp-symlink will still complain
197 # about missing link targets, but it won't stop rpmbuild from generating
199 # For all other Unix distros, this is a no-op.
200 export NO_BRP_STALE_LINK_ERROR
=yes
203 make install DESTDIR
=$RPM_BUILD_ROOT
205 # Creation of foam-extend specific .csh and .sh files"
208 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
211 # Generate package specific .sh file for foam-extend
213 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
214 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
215 # Load %{name}-%{version} libraries and binaries if available
216 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
218 export PARAVIEW_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
219 export PARAVIEW_BIN_DIR
=\$PARAVIEW_DIR
/bin
220 export PARAVIEW_LIB_DIR
=\$PARAVIEW_DIR
/lib
221 export PARAVIEW_INCLUDE_DIR
=\$PARAVIEW_DIR
/include
/paraview
-4.1
223 export PARAVIEW_VERSION
=%{version}
225 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
226 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
227 # specified directory to see if a given library is a paraview plugin.
228 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
229 # startup of paraview or even make paraview crash on startup.
230 export PV_PLUGIN_PATH
=\$FOAM_LIBBIN
/paraview_plugins
232 [ -d \$PARAVIEW_LIB_DIR
/paraview
-4.1 ] && _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-4.1
234 # Enable access to the package applications if present
235 [ -d \$PARAVIEW_BIN_DIR
] && _foamAddPath \$PARAVIEW_BIN_DIR
237 # Additional binary path if running on Mac OS X
238 [ -d \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
] && _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
243 # Generate package specific .csh file for foam-extend
245 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
246 # Load %{name}-%{version} libraries and binaries if available
247 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
248 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
249 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR
/bin
250 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR
/lib
251 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR
/include
/paraview
-4.1
253 setenv PARAVIEW_VERSION
%{version}
255 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
256 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
257 # specified directory to see if a given library is a paraview plugin.
258 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
259 # startup of paraview or even make paraview crash on startup.
260 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN
/paraview_plugins
262 if ( -e \$PARAVIEW_BIN_DIR
) then
263 _foamAddPath \$PARAVIEW_BIN_DIR
266 if ( -e \$PARAVIEW_LIB_DIR
/paraview
-4.1 ) then
267 _foamAddLib \$PARAVIEW_LIB_DIR
/paraview
-4.1
271 # Additional binary path if running on Mac OS X
272 if ( -e \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
) then
273 _foamAddPath \$PARAVIEW_BIN_DIR
/paraview.app
/Contents
/MacOS
277 #finally, generate a .tgz file for systems where using rpm for installing packages
278 # as a non-root user might be a problem.
279 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
284 %defattr(-,root
,root
)