Merge branch 'master' of ssh://git.code.sf.net/p/foam-extend/foam-extend-3.2
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / ParaView-4.3.1_Server.spec
blobbe845b751161a8b0cfcd626cb9fc1e8797b81c27
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for ParaView-4.3.1_Server
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Authors:
31 # Martin Beaudoin, Hydro-Quebec, (2010, 2015)
32 # Andreas Feymark, Chalmers University of Technology, (2013)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 %{expand:%%define _MPI_ARCH_PATH %(echo $MPI_ARCH_PATH)}
40 %{expand:%%define _MESA_DIR %(echo $MESA_DIR)}
42 # Disable the generation of debuginfo packages
43 %define debug_package %{nil}
45 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
46 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
47 %define _tmppath %{_topdir}/tmp
49 # Will install the package directly $WM_THIRD_PARTY_DIR
50 # Some comments about package relocation:
51 # By using this prefix for the Prefix: parameter in this file, you will make this
52 # package relocatable.
54 # This is fine, as long as your software is itself relocatable.
56 # Simply take note that libraries built with libtool are not relocatable because the
57 # prefix we specify will be hard-coded in the library .la files.
58 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
60 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
61 # not be able to reutilize this RPM, even though it is relocatable. You will need to
62 # regenerate the RPM.
64 %define _prefix %{_WM_THIRD_PARTY_DIR}
66 %define name ParaView
67 %define release %{_WM_OPTIONS}
68 %define version 4.3.1_Server
70 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
72 BuildRoot: %{buildroot}
73 Summary: ParaView
74 License: Unkown
75 Name: %{name}
76 Version: %{version}
77 Release: %{release}
78 URL: http://www.paraview.org/files/v4.3/
79 Source: %url/%{name}-v4.3.1-source.tar.gz
80 Prefix: %{_prefix}
81 Group: Development/Tools
82 Patch0: ParaView-v4.3.1.patch_darwin
84 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
86 #--------------------------------------------------------------------------
88 # Here, we define default compiling options for cmake
90 # One can override the option on the commande line : --define='MACRO EXPR'
92 %{!?_withVerbose: %define _withVerbose false}
93 %{!?_withMesa: %define _withMesa false}
94 %{!?_withMPI: %define _withMPI false}
95 %{!?_withPython: %define _withPython false}
96 %{!?_withQt: %define _withQt true}
97 %{!?_qmakePath: %define _qmakePath Undefined}
98 %{!?_mesaIncludePath: %define _mesaIncludePath Undefined}
99 %{!?_mesaLibPath: %define _mesaLibPath Undefined}
100 %{!?_pythonLibPath: %define _pythonLibPath Undefined}
102 #--------------------------------------------------------------------------
104 %description
105 %{summary}
107 %prep
108 %setup -q -n %{name}-v4.3.1-source
110 %ifos darwin
111 %patch0 -p1
112 %endif
115 %build
117 # set CMake cache variables
119 addCMakeVariable()
121 echo "Adding: $1"
122 while [ -n "$1" ]
124 CMAKE_VARIABLES="$CMAKE_VARIABLES -D$1"
125 shift
126 done
129 # export WM settings in a form that GNU configure recognizes
130 [ -n "$WM_CC" ] && export CC="$WM_CC"
131 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
132 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
133 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
134 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
136 set +x
137 echo ""
138 echo "Compilation options:"
139 echo " _withVerbose : %{_withVerbose}"
140 echo " _withMesa : %{_withMesa}"
141 echo " _withMPI : %{_withMPI}"
142 echo " _withPython : %{_withPython}"
143 echo " _withQt : %{_withQt}"
144 echo " _qmakePath : %{_qmakePath}"
145 echo " _mesaIncludePath : %{_mesaIncludePath}"
146 echo " _mesaLibPath : %{_mesaLibPath}"
147 echo " _pythonLibPath : %{_pythonLibPath}"
148 echo ""
149 set -x
151 # start with these general settings
152 addCMakeVariable BUILD_SHARED_LIBS:BOOL=ON
153 addCMakeVariable CMAKE_BUILD_TYPE:STRING=Release
154 addCMakeVariable BUILD_TESTING:BOOL=OFF
156 # Setings specific to ParaView server
157 addCMakeVariable PARAVIEW_USE_MPI=ON
158 addCMakeVariable PARAVIEW_BUILD_QT_GUI=OFF
159 addCMakeVariable VTK_USE_X=OFF
160 addCMakeVariable OPENGL_INCLUDE_DIR=%{_MESA_DIR}
161 addCMakeVariable OPENGL_gl_LIBRARY=%{_MESA_DIR}/lib/libOSMesa.so
162 addCMakeVariable VTK_OPENGL_HAS_OSMESA=ON
164 # We build with Python. This is just too useful
165 addCMakeVariable PARAVIEW_ENABLE_PYTHON:BOOL=ON
167 %ifos darwin
168 # Additional installation rules for Mac OS X
169 addCMakeVariable PARAVIEW_EXTRA_INSTALL_RULES_FILE:FILEPATH=%{_topdir}/BUILD/%{name}-%{version}/Applications/ParaView-3.8.1_extra_install_Darwin.cmake
170 %endif
172 # Add the value of _qmakePath for QT_QMAKE_EXECUTABLE
173 addCMakeVariable QT_QMAKE_EXECUTABLE:FILEPATH=%{_qmakePath}
175 echo "CMAKE_VARIABLES: $CMAKE_VARIABLES"
177 mkdir -p ./buildObj
178 cd ./buildObj
180 cmake \
181 -DCMAKE_INSTALL_PREFIX:PATH=%{_installPrefix} \
182 $CMAKE_VARIABLES \
185 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
186 make -j $WM_NCOMPPROCS
188 %install
189 # On OpenSUSE, rpmbuild, will choke when detecting unreferenced symlinks
190 # created during installation.
191 # Qt version 4.6.3 will generate some unreferenced symlinks when
192 # ParaView is compiled and installed. By enabling the following
193 # environment variable, the command brp-symlink will still complain
194 # about missing link targets, but it won't stop rpmbuild from generating
195 # the final rpm.
196 # For all other Unix distros, this is a no-op.
197 export NO_BRP_STALE_LINK_ERROR=yes
199 cd buildObj
200 make install DESTDIR=$RPM_BUILD_ROOT
202 # Creation of foam-extend specific .csh and .sh files"
204 echo ""
205 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
206 echo ""
208 # Generate package specific .sh file for foam-extend
210 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
211 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
212 # Load %{name}-%{version} libraries and binaries if available
213 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
215 export PARAVIEW_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
216 export PARAVIEW_BIN_DIR=\$PARAVIEW_DIR/bin
217 export PARAVIEW_LIB_DIR=\$PARAVIEW_DIR/lib
218 export PARAVIEW_INCLUDE_DIR=\$PARAVIEW_DIR/include/paraview-4.3
220 export PARAVIEW_VERSION=%{version}
222 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
223 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
224 # specified directory to see if a given library is a paraview plugin.
225 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
226 # startup of paraview or even make paraview crash on startup.
227 export PV_PLUGIN_PATH=\$FOAM_LIBBIN/paraview_plugins
229 [ -d \$PARAVIEW_LIB_DIR/paraview-4.3 ] && _foamAddLib \$PARAVIEW_LIB_DIR/paraview-4.3
231 # Enable access to the package applications if present
232 [ -d \$PARAVIEW_BIN_DIR ] && _foamAddPath \$PARAVIEW_BIN_DIR
234 # Additional binary path if running on Mac OS X
235 [ -d \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS ] && _foamAddPath \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS
237 DOT_SH_EOF
240 # Generate package specific .csh file for foam-extend
242 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
243 # Load %{name}-%{version} libraries and binaries if available
244 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
245 setenv PARAVIEW_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
246 setenv PARAVIEW_BIN_DIR \$PARAVIEW_DIR/bin
247 setenv PARAVIEW_LIB_DIR \$PARAVIEW_DIR/lib
248 setenv PARAVIEW_INCLUDE_DIR \$PARAVIEW_DIR/include/paraview-4.3
250 setenv PARAVIEW_VERSION %{version}
252 # NB: It is important to set the PV_PLUGIN_PATH location to a directory containing only the ParaView plugins.
253 # Otherwise, paraview will try to automatically autoload each and every dynamic library it can find in the
254 # specified directory to see if a given library is a paraview plugin.
255 # In the case of \$FOAM_LIBBIN, with over 80 libraries, this is a total waste of time that will slow down the
256 # startup of paraview or even make paraview crash on startup.
257 setenv PV_PLUGIN_PATH \$FOAM_LIBBIN/paraview_plugins
259 if ( -e \$PARAVIEW_BIN_DIR ) then
260 _foamAddPath \$PARAVIEW_BIN_DIR
261 endif
263 if ( -e \$PARAVIEW_LIB_DIR/paraview-4.3 ) then
264 _foamAddLib \$PARAVIEW_LIB_DIR/paraview-4.3
265 endif
268 # Additional binary path if running on Mac OS X
269 if ( -e \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS ) then
270 _foamAddPath \$PARAVIEW_BIN_DIR/paraview.app/Contents/MacOS
271 endif
272 DOT_CSH_EOF
274 #finally, generate a .tgz file for systems where using rpm for installing packages
275 # as a non-root user might be a problem.
276 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
278 %clean
280 %files
281 %defattr(-,root,root)
282 %{_installPrefix}