1 #------------------------------------------------------------------------------
3 # \\ / F ield | foam-extend: Open Source CFD
5 # \\ / A nd | For copyright notice see file Copyright
7 #------------------------------------------------------------------------------
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
25 # RPM spec file for Zoltan-3.5
28 # RPM spec file for creating a relocatable RPM
31 # Martin Beaudoin, Hydro-Quebec, (2011)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package
%{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath
%{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
61 %define _prefix
%{_WM_THIRD_PARTY_DIR}
64 %define release
%{_WM_OPTIONS}
67 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
75 URL: http
://www.cs.sandia.gov
/~kddevin
/Zoltan_Distributions
76 Source: %url/zoltan_distrib_v
%{version}.tar.gz
78 Group: Development
/Tools
80 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
86 %setup -q
-n Zoltan_v3.5
93 --with
-mpi
=$MPI_HOME \
94 --prefix
=%{_installPrefix}
96 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
97 make -j $WM_NCOMPPROCS everything
101 make install DESTDIR
=$RPM_BUILD_ROOT
102 cp .
/src
/include
/Zoltan_config.h $RPM_BUILD_ROOT
/%{_installPrefix}/include
104 # Creation of foam-extend specific .csh and .sh files"
107 echo "Generating foam
-extend specific .csh and .sh files
for the package
%{name}-%{version}"
110 # Generate package specific .sh file for foam-extend
112 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
113 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
114 # Load %{name}-%{version} libraries and binaries if available
115 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
117 export ZOLTAN_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
119 [ -d \$ZOLTAN_DIR
/lib
] && _foamAddLib \$ZOLTAN_DIR
/lib
121 # Enable access to the package applications if present
122 [ -d \$ZOLTAN_DIR
/bin
] && _foamAddPath \$ZOLTAN_DIR
/bin
126 # Generate package specific .csh file for foam-extend
128 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
129 # Load %{name}-%{version} libraries and binaries if available
130 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
131 setenv ZOLTAN_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
133 if ( -e \$ZOLTAN_DIR
/lib
) then
134 _foamAddLib \$ZOLTAN_DIR
/lib
137 if ( -e \$ZOLTAN_DIR
/bin
) then
138 _foamAddPath \$ZOLTAN_DIR
/bin
142 #finally, generate a .tgz file for systems where using rpm for installing packages
143 # as a non-root user might be a problem.
144 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
151 %defattr(-,root
,root
)