*/*: breaken package drop keywords
[gentoo-zh.git] / app-i18n / scim-chrasis / scim-chrasis-9999.0.0.1.ebuild
blobbfb6ce9616f407ca99f606be501c372401f487e3
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils subversion
8 DESCRIPTION="Chrasis SCIM binding for chinese character recognition."
9 HOMEPAGE="http://chrasis.berlios.de/"
10 #SRC_URI=""
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="nls"
17 DEPEND=">=app-i18n/scim-1.2.0
18 >=x11-libs/gtk+-2.12.0
19 dev-libs/libchrasis"
21 RDEPEND="${DEPEND}"
23 src_unpack()
25 ESVN_REPO_URI="svn://svn.berlios.de/chrasis/Linux/scim-chrasis/trunk"
26 ESVN_PROJECT="scim-chrasis"
27 #ESVN_PATCHES="*.diff"
28 #ESVN_BOOTSTRAP="./autogen.sh"
29 subversion_src_unpack
32 src_compile() {
33 glib-gettextize -f
34 ./autogen.sh
35 econf $(use_enable nls) || die "Error: econf failed!"
36 emake || die "Error: emake failed!"
39 src_install() {
40 make DESTDIR=${D} install || die "Error: install failed!"
41 dodoc ChangeLog README
44 #pkg_postinst() {
46 # elog
47 # elog "The SCIM input pad should be startable from the SCIM (and Skim)"
48 # elog "systray icon right click menu. You will have to restart SCIM"
49 # elog "(or Skim) in order for the menu entry to appear (you may simply"
50 # elog "restart your X server). If you want to use it immediately, just"
51 # elog "start the SCIM input pad, using the 'scim-input-pad' command."
52 # elog
53 # elog "To use, select the text zone you wish to write in, and just"
54 # elog "click on the wanted character in the right multilevel tabbed"
55 # elog "table, from the SCIM Input Pad interface."
56 # elog
57 # elog "To add new characters to the tables, see the documentation"
58 # elog "(/usr/share/doc/${PF}/README.gz)."
59 # elog