net-im/tencent-qq: rename version
[gentoo-zh.git] / app-i18n / fcitx5 / fcitx5-5.0.9.ebuild
blob37280df27952bf0156f7caedca4e03abe5a8f5aa
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit cmake xdg
8 if [[ "${PV}" == 9999 ]]; then
9 inherit git-r3
10 EGIT_REPO_URI="https://github.com/fcitx/fcitx5.git"
11 KEYWORDS=""
12 else
13 SRC_URI="https://github.com/fcitx/fcitx5/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
14 KEYWORDS="~amd64 ~x86"
17 DESCRIPTION="Fcitx5 Next generation of fcitx "
18 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
19 SRC_URI+=" https://download.fcitx-im.org/data/en_dict-20121020.tar.gz -> fcitx-data-en_dict-20121020.tar.gz"
21 LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
22 SLOT="5"
23 IUSE="+enchant test coverage doc presage systemd wayland +X"
24 REQUIRED_USE="
25 || ( wayland X )
26 coverage? ( test )
29 RDEPEND="dev-libs/glib:2
30 sys-apps/dbus
31 dev-libs/json-c
32 dev-libs/libfmt
33 sys-apps/util-linux
34 virtual/libiconv
35 virtual/libintl
36 x11-libs/libxkbcommon[X?]
37 wayland? (
38 dev-libs/wayland
39 dev-libs/wayland-protocols
41 X? (
42 x11-libs/libX11
43 x11-libs/libXext
44 x11-libs/libXfixes
45 x11-libs/libXrender
47 x11-libs/libXinerama
48 x11-libs/libxkbfile
49 x11-libs/xcb-imdkit
50 x11-misc/xkeyboard-config
51 x11-libs/cairo[X]
52 x11-libs/pango
53 media-libs/fontconfig
54 enchant? ( app-text/enchant:= )
55 systemd? ( sys-apps/systemd )
56 app-text/iso-codes
57 app-i18n/unicode-cldr
58 dev-libs/libxml2
59 dev-libs/libevent"
60 DEPEND="${RDEPEND}
61 kde-frameworks/extra-cmake-modules:5
62 virtual/pkgconfig"
64 src_prepare() {
65 pwd
66 ln -s "${DISTDIR}/fcitx-data-en_dict-20121020.tar.gz" src/modules/spell/dict/en_dict-20121020.tar.gz || die
68 cmake_src_prepare
71 src_configure() {
72 local mycmakeargs=(
73 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
74 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
75 -DENABLE_TEST=$(usex test)
76 -DENABLE_COVERAGE=$(usex coverage)
77 -DENABLE_ENCHANT=$(usex enchant)
78 -DENABLE_PRESAGE=$(usex presage)
79 -DENABLE_WAYLAND=$(usex wayland)
80 -DENABLE_X11=$(usex X)
81 -DENABLE_DOC=$(usex doc)
82 -DUSE_SYSTEMD=$(usex systemd)
84 cmake_src_configure
87 pkg_postinst() {
88 xdg_pkg_postinst
90 elog
91 elog "Follow the instrcutions of https://wiki.gentoo.org/wiki/Fcitx#Using_Fcitx"
92 elog "and change the fcitx to fcitx5"
93 elog