1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 if [[ "${PV}" == 9999 ]]; then
10 EGIT_REPO_URI
="https://github.com/fcitx/fcitx5.git"
13 SRC_URI
="https://github.com/fcitx/fcitx5/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
14 KEYWORDS
="~amd64 ~x86"
17 DESCRIPTION
="Fcitx5 Next generation of fcitx "
18 HOMEPAGE
="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
19 SRC_URI
+=" https://download.fcitx-im.org/data/en_dict-20121020.tar.gz -> fcitx-data-en_dict-20121020.tar.gz"
21 LICENSE
="BSD-1 GPL-2+ LGPL-2+ MIT"
23 IUSE
="+enchant test coverage doc presage systemd wayland +X"
29 RDEPEND
="dev-libs/glib:2
36 x11-libs/libxkbcommon[X?]
39 dev-libs/wayland-protocols
50 x11-misc/xkeyboard-config
54 enchant? ( app-text/enchant:= )
55 systemd? ( sys-apps/systemd )
61 kde-frameworks/extra-cmake-modules:5
66 ln -s "${DISTDIR}/fcitx-data-en_dict-20121020.tar.gz" src
/modules
/spell
/dict
/en_dict-20121020.
tar.gz || die
73 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
74 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
75 -DENABLE_TEST=$
(usex
test)
76 -DENABLE_COVERAGE=$
(usex coverage
)
77 -DENABLE_ENCHANT=$
(usex enchant
)
78 -DENABLE_PRESAGE=$
(usex presage
)
79 -DENABLE_WAYLAND=$
(usex wayland
)
80 -DENABLE_X11=$
(usex X
)
81 -DENABLE_DOC=$
(usex doc
)
82 -DUSE_SYSTEMD=$
(usex systemd
)
91 elog
"Follow the instrcutions of https://wiki.gentoo.org/wiki/Fcitx#Using_Fcitx"
92 elog
"and change the fcitx to fcitx5"