1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
52 bytecheck_derive@0.6.12
67 concurrent-queue@2.5.0
72 core-foundation-sys@0.8.7
73 core-foundation@0.10.0
75 core-graphics-types@0.2.0
79 crossbeam-channel@0.5.13
80 crossbeam-utils@0.8.20
90 derive_is_enum_variant@0.1.1
97 documented-macros@0.6.0
107 enumflags2_derive@0.7.10
110 event-listener-strategy@0.5.2
117 foreign-types-macros@0.2.3
118 foreign-types-shared@0.1.1
119 foreign-types-shared@0.3.1
122 form_urlencoded@1.2.1
124 from_variants_impl@1.0.2
126 futures-channel@0.3.30
128 futures-executor@0.3.30
135 gdk-pixbuf-sys@0.18.0
136 gdk-pixbuf-sys@0.20.4
201 libappindicator-sys@0.9.0
202 libappindicator@0.9.0
208 libmimalloc-sys@0.1.39
224 minimal-lexical@0.2.1
239 objc-foundation@0.1.1
242 objc2-core-data@0.2.2
243 objc2-core-image@0.2.2
245 objc2-foundation@0.2.2
247 objc2-quartz-core@0.2.2
268 parking_lot_core@0.9.10
270 percent-encoding@2.3.1
275 pin-project-lite@0.2.14
286 proc-macro-crate@1.3.1
287 proc-macro-crate@2.0.0
288 proc-macro-crate@3.2.0
289 proc-macro-error-attr@1.0.4
290 proc-macro-error@1.0.4
294 ptr_meta_derive@0.1.4
304 raw-window-handle@0.6.2
307 regex-automata@0.1.10
320 rust_decimal_macros@1.36.0
321 rustc-demangle@0.1.24
325 rustls-pki-types@1.9.0
326 rustls-webpki@0.102.8
334 security-framework-sys@2.12.0
335 security-framework@2.11.1
342 serde_urlencoded@0.7.1
346 signal-hook-registry@1.4.2
357 static_assertions@1.1.0
370 system-configuration-sys@0.6.0
371 system-configuration@0.6.1
375 target-lexicon@0.12.16
379 thiserror-impl@1.0.64
388 tokio-native-tls@0.3.1
398 tracing-attributes@0.1.27
400 tracing-journald@0.3.0
402 tracing-subscriber@0.3.18
410 unicode-normalization@0.1.24
411 unicode-segmentation@1.12.0
421 version-compare@0.2.0
426 wasi@0.11.0+wasi-snapshot-preview1
427 wasm-bindgen-backend@0.2.93
428 wasm-bindgen-futures@0.4.43
429 wasm-bindgen-macro-support@0.2.93
430 wasm-bindgen-macro@0.2.93
431 wasm-bindgen-shared@0.2.93
433 wayland-backend@0.3.7
434 wayland-client@0.31.6
435 wayland-protocols@0.32.4
436 wayland-scanner@0.31.5
439 winapi-i686-pc-windows-gnu@0.4.0
440 winapi-x86_64-pc-windows-gnu@0.4.0
443 windows-implement@0.58.0
444 windows-interface@0.58.0
445 windows-registry@0.2.0
447 windows-strings@0.1.0
451 windows-targets@0.48.5
452 windows-targets@0.52.6
454 windows_aarch64_gnullvm@0.48.5
455 windows_aarch64_gnullvm@0.52.6
456 windows_aarch64_msvc@0.48.5
457 windows_aarch64_msvc@0.52.6
458 windows_exe_info@0.4.2
459 windows_i686_gnu@0.48.5
460 windows_i686_gnu@0.52.6
461 windows_i686_gnullvm@0.52.6
462 windows_i686_msvc@0.48.5
463 windows_i686_msvc@0.52.6
464 windows_x86_64_gnu@0.48.5
465 windows_x86_64_gnu@0.52.6
466 windows_x86_64_gnullvm@0.48.5
467 windows_x86_64_gnullvm@0.52.6
468 windows_x86_64_msvc@0.48.5
469 windows_x86_64_msvc@0.52.6
480 zerocopy-derive@0.7.35
484 zvariant_derive@4.2.0
488 PLOCALES
="en_US it_IT zh_CN"
489 PLOCALE_BACKUP
="en_US"
490 inherit cargo desktop gnome2-utils plocale xdg
492 DESCRIPTION
="Simple On Screen lyrics Display for linux/unix"
494 https://waylyrics.github.io/waylyrics/waylyrics
495 https://github.com/waylyrics/waylyrics
498 if [[ "${PV}" == *9999* ]]; then
500 EGIT_REPO_URI
="https://github.com/waylyrics/waylyrics.git"
503 https://github.com/waylyrics/waylyrics/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
506 KEYWORDS
="~amd64 ~loong"
509 LICENSE
="MIT CC-BY-4.0"
510 # Dependent crate licenses
512 Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD GPL-3+ ISC MIT
513 MPL-2.0 Unicode-DFS-2016 Unlicense
529 sys-apps/xdg-desktop-portal
532 >=virtual/rust-1.73:*
536 export WAYLYRICS_THEME_PRESETS_DIR
="/usr/share/${PN}/themes"
537 cargo_src_compile
--all-targets --all-features
543 doicon
-s scalable
"${S}/res/icons/hicolor/scalable/apps/io.github.waylyrics.Waylyrics.svg"
544 domenu
"${S}/metainfo/io.github.waylyrics.Waylyrics.desktop"
546 insinto
"/usr/share/glib-2.0/schemas"
547 doins
"${S}/metainfo/io.github.waylyrics.Waylyrics.gschema.xml"
549 insinto
"/usr/share/metainfo"
550 doins
"${S}/metainfo/io.github.waylyrics.Waylyrics.metainfo.xml"
552 insinto
"/usr/share/${PN}"
555 cd "${S}/locales" || die
557 if [[ -f ${1}/LC_MESSAGES
/waylyrics.po
]]; then
558 local file=${1}/LC_MESSAGES
/waylyrics.po
559 msgfmt
"${file}" -o "${file%.po}.mo" || die
560 insinto
/usr
/share
/locale
/${1}/LC_MESSAGES
561 doins
"${file%.po}.mo"
564 plocale_for_each_locale install_locale
568 gnome2_schemas_update
573 gnome2_schemas_update