1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop unpacker xdg
8 DESCRIPTION
="Brainstorming and Mind Mapping Software"
9 HOMEPAGE
="https://www.xmind.net"
10 SRC_URI
="https://dl3.xmind.net/Xmind-for-Linux-amd64bit-${PV}.deb"
12 LICENSE
="all-rights-reserved"
15 RESTRICT
="mirror strip"
30 fperms
+x
/opt
/Xmind
/{xmind
,chrome_crashpad_handler
,chrome-sandbox
,libEGL.so
,libffmpeg.so
,libGLESv2.so
,libvk_swiftshader.so
,libvulkan.so
.1}
31 dosym
-r "/opt/Xmind/xmind" "/usr/bin/xmind"
32 for size
in 16 32 48 64 128 256 512 1024; do
33 doicon
-s $size usr
/share
/icons
/hicolor
/"$size"x
"$size"/apps
/xmind.png
35 insinto
/usr
/share
/mime
/packages
36 doins usr
/share
/mime
/packages
/xmind.xml
37 domenu usr
/share
/applications
/xmind.desktop
38 gzip -d usr
/share
/doc
/xmind-vana
/changelog.gz || die
39 dodoc usr
/share
/doc
/xmind-vana
/changelog