1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit desktop eutils pax-utils xdg
10 DESCRIPTION
="Supercharge your API workflow"
11 HOMEPAGE
="https://www.getpostman.com"
13 amd64? ( https://dl.pstmn.io/download/version/${PV}/linux64 -> ${P}-amd64.tar.gz )
20 RESTRICT
="bindist mirror strip"
27 QA_FLAGS_IGNORED
="CFLAGS LDFLAGS"
29 S
="${WORKDIR}/${MY_PN^}/app"
37 local dir
="/opt/${PN}"
41 fperms
755 "${dir}"/Postman
42 fperms
755 "${dir}"/postman
44 make_wrapper
"${PN}" "${dir}/Postman"
45 newicon
"resources/app/assets/icon.png" "${PN}.png"
46 make_desktop_entry
"${PN}" "Postman" "${PN}" "Development;IDE;"