dev-python/fuo-netease: update SRC_URI
[gentoo-zh.git] / net-misc / postman-bin / postman-bin-9.6.1.ebuild
blob430be08ee533a98f33b8d1f6e0fa12e516b6f3c8
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit desktop eutils pax-utils xdg
8 MY_PN="${PN/-bin/}"
10 DESCRIPTION="Supercharge your API workflow"
11 HOMEPAGE="https://www.getpostman.com"
12 SRC_URI="
13 amd64? ( https://dl.pstmn.io/download/version/${PV}/linux64 -> ${P}-amd64.tar.gz )
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20 RESTRICT="bindist mirror strip"
22 DEPEND=""
23 RDEPEND="
24 x11-libs/gtk+
27 QA_FLAGS_IGNORED="CFLAGS LDFLAGS"
29 S="${WORKDIR}/${MY_PN^}/app"
31 src_prepare() {
32 mv _Postman Postman
33 default
36 src_install() {
37 local dir="/opt/${PN}"
39 insinto "${dir}"
40 doins -r *
41 fperms 755 "${dir}"/Postman
42 fperms 755 "${dir}"/postman
44 make_wrapper "${PN}" "${dir}/Postman"
45 newicon "resources/app/assets/icon.png" "${PN}.png"
46 make_desktop_entry "${PN}" "Postman" "${PN}" "Development;IDE;"