app-i18n/gcin: version bump
[gentoo-zh.git] / dev-libs / dbus-c++ / dbus-c++-0.5.0.ebuild
blobb2ca1069475733eb5af1f0207c97bf259d07396f
1 # Copyright 1999-2010 Mat
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header:
5 EAPI="2"
7 inherit git autotools
9 DESCRIPTION="dbus-c++ attempts to provide a C++ API for D-BUS."
10 HOMEPAGE="http://www.freedesktop.org/wiki/Software/dbus-c++"
12 EGIT_REPO_URI="git://gitorious.org/dbus-cplusplus/mainline.git"
13 EGIT_BOOTSTRAP="./autogen.sh"
14 EGIT_COMMIT="9ac4f0252f0784e8594b41e578e6d04f89835d13"
15 #EGIT_PATCHES=""
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="debug"
22 # probably needs more/less crap listed here ...
23 RDEPEND="sys-apps/dbus"
24 DEPEND="${RDEPEND}
25 dev-vcs/git
26 dev-util/pkgconfig"
28 src_compile() {
29 econf $(use_enable debug ) || die
30 emake -j1 || die "emake failed"