app-text/openyoudao: drop, because dev-python/pywebkitgtk has been drop (#1023)
[gentoo-zh.git] / dev-python / tomlkit / tomlkit-0.7.0-r1.ebuild
blobacadf042b0df628373c3f008342719d9871142a1
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 DISTUTILS_USE_SETUPTOOLS=pyproject.toml
6 PYTHON_COMPAT=( python3_{8,9} pypy3 )
7 inherit distutils-r1
9 DESCRIPTION="Style-preserving TOML library for Python"
10 HOMEPAGE="https://github.com/sdispater/tomlkit"
11 MY_P="${P/_alpha/a}"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
13 IUSE="test"
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="~amd64"
19 DEPEND="
20 dev-python/setuptools[${PYTHON_USEDEP}]
21 test? (
22 dev-python/pytest[${PYTHON_USEDEP}]
26 src_prepare() {
27 sed -i -e '/{include = "tests", format = "sdist"}/d' pyproject.toml || die
28 sed -i -e 's/{include = "tomlkit"},/{include = "tomlkit"}/' pyproject.toml || die
29 rm setup.py
30 distutils-r1_src_prepare
33 python_test() {
34 py.test -v || die "Tests fail with ${EPYTHON}"