dev-java/google-java-format: add 1.25.0, drop 1.24.0
[gentoo-zh.git] / net-analyzer / nali / nali-0.8.1.ebuild
blob1ac555a17a6bcd2ef66d2086af043c09c4c401ee
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
7 DESCRIPTION="An offline tool for querying IP geographic information and CDN provider."
8 HOMEPAGE="https://github.com/zu1k/nali"
10 SRC_URI="
11 https://github.com/zu1k/nali/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm64"
19 src_compile() {
20 local ldflags="\
21 -X \"github.com/zu1k/nali/internal/constant.Version=${PV}\" \
22 -w -s"
23 ego build -trimpath -ldflags "${ldflags}"
26 src_install() {
27 dobin ${PN}