1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 MULTILIB_COMPAT
=( abi_mips_n64
)
8 inherit desktop xdg-utils unpacker
10 DESCRIPTION
="feishu - ByteDance's enterprise collaboration platform"
11 HOMEPAGE
="https://www.feishu.cn/"
13 amd64? ( https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/${PN}-beta_4.8.0-24_amd64.deb )
14 arm64? ( https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/${PN}-beta_4.8.0-24_arm64.deb )
15 mips? ( https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/${PN}-beta_4.8.0-24_mips64el.deb )
18 LICENSE
="bytedance-feishu"
20 KEYWORDS
="-* ~amd64 ~arm64 ~mips"
22 REQUIRED_USE
="mips? ( !big-endian )"
26 dev-util/desktop-file-utils
37 QA_PREBUILT
="opt/bytedance/*"
41 sed -i 's/Application;//g' usr
/share
/applications
/bytedance-feishu.desktop || die
42 rm -r usr
/share
/menu || die
43 gzip -d "usr/share/man/man1/${PN}-beta.1.gz" || die
44 gzip -d "usr/share/doc/${PN}-beta/changelog.gz" || die
48 insinto
"/opt/bytedance"
49 doins
-r "opt/bytedance/feishu"
50 fperms
+x
"/opt/bytedance/feishu/"{bytedance-feishu
,chrome-sandbox
,lark
}
51 fperms
+x
"/opt/bytedance/feishu/vulcan/vulcan"
54 for size
in 16 24 32 48 64 128 256 ; do
55 newicon
-s ${size} "opt/bytedance/feishu/product_logo_${size}.png" ${PN}.png
58 dosym
"../../opt/bytedance/feishu/${PN}" "/usr/bin/${PN}-beta"
59 domenu
"usr/share/applications/${PN}.desktop"
60 doman
"usr/share/man/man1/${PN}-beta.1"
61 dodoc
"usr/share/doc/${PN}-beta/changelog"