wine, use new multilib style to depend on 32bit gtk
[gentoo-zh.git] / net-im / wineqq / wineqq-20140102.ebuild
blob8288f4233ab333ec934b3ed44060a6b7c8a10325
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=5
7 inherit eutils
9 DESCRIPTION="Tencent QQ for Linux by longine"
10 HOMEPAGE="http://www.longene.org/"
11 SRC_URI="http://www.longene.org/download/WineQQ2013SP6-${PV}-Longene.deb"
13 LICENSE="Tencent"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="system-wine"
18 RDEPEND="
19 x11-libs/gtk+:2[x86_abi_32]
21 system-wine? (
22 >=app-emulation/wine-1.7.16[abi_x86_32,-abi_x86_x32,-abi_x86_64,fontconfig,mp3,truetype,X,nls,xml]
26 RESTRICT="mirror strip"
28 QA_PRESTRIPPED="opt/linuxqq/qq"
30 S=$WORKDIR
32 src_install() {
33 tar xzvf data.tar.gz -C ${D}/
35 chmod 755 ${D}/opt
36 chmod 755 ${D}/usr
37 chown -R root:root ${D}
38 cp ${D}/opt/longene/qq/qq-test.desktop ${D}/usr/share/applications/
39 if use system-wine ; then
40 rm ${D}/opt/longene/qq/wine-lib/bin -rf
41 ln -svf /usr/bin ${D}/opt/longene/qq/wine-lib/bin
42 rm -rf ${D}/opt/longene/qq/wine-lib/lib
46 pkg_postinst() {
47 elog
48 elog "Some user reported that some fonts could not display."
49 elog "It was a system environment related issue."
50 elog "If you have that issue, check Issue #92 (https://github.com/microcai/gentoo-zh/issues/92) to find out possible solution."
51 elog