net-analyzer/realitlscanner: add 0.1.2, drop 0.1.0
[gentoo-zh.git] / app-containers / distrobox-boost / distrobox-boost-9999.ebuild
blob975e31f4ca5e8d1492918655b6fc8df46c206ba9
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Auto-Generated by cargo-ebuild 0.5.4-r1
6 EAPI=8
8 CRATES="
9 anstream@0.5.0
10 anstyle@1.0.3
11 anstyle-parse@0.2.1
12 anstyle-query@1.0.0
13 anstyle-wincon@2.1.0
14 clap@4.4.4
15 clap_builder@4.4.4
16 clap_derive@4.4.2
17 clap_lex@0.5.1
18 colorchoice@1.0.0
19 heck@0.4.1
20 lazy_static@1.4.0
21 proc-macro2@1.0.67
22 quote@1.0.33
23 strsim@0.10.0
24 syn@2.0.37
25 unicode-ident@1.0.12
26 utf8parse@0.2.1
27 windows-sys@0.48.0
28 windows-targets@0.48.5
29 windows_aarch64_gnullvm@0.48.5
30 windows_aarch64_msvc@0.48.5
31 windows_i686_gnu@0.48.5
32 windows_i686_msvc@0.48.5
33 windows_x86_64_gnu@0.48.5
34 windows_x86_64_gnullvm@0.48.5
35 windows_x86_64_msvc@0.48.5
38 inherit cargo
40 DESCRIPTION="A container runtimer wrapper for OCI (distrobox/toolbox, also podman/docker)"
41 # Double check the homepage as the cargo_metadata crate
42 # does not provide this value so instead repository is used
43 HOMEPAGE="https://github.com/xz-dev/distrobox-boost"
44 SRC_URI="${CARGO_CRATE_URIS}"
45 if [[ ${PV} == 9999 ]]; then
46 inherit git-r3
47 EGIT_REPO_URI="https://github.com/xz-dev/${PN}.git"
48 else
49 SRC_URI+=" https://github.com/xz-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
52 # License set may be more restrictive as OR is not respected
53 # use cargo-license for a more accurate license picture
54 LICENSE="MIT"
55 SLOT="0"
56 KEYWORDS="~amd64 ~x86"
58 DEPEND="app-containers/distrobox"
59 RDEPEND="${DEPEND}"
61 # rust does not use *FLAGS from make.conf, silence portage warning
62 # update with proper path to binaries this crate installs, omit leading /
63 QA_FLAGS_IGNORED="usr/bin/${PN}"
65 src_unpack() {
66 if [[ ${PV} = *9999* ]]; then
67 git-r3_src_unpack
68 cargo_live_src_unpack
69 else
70 cargo_src_unpack