get the right patch.
[gentoo-zh.git] / x11-terms / lilyterm / lilyterm-0.9.7.ebuild
blob0f9b0941c9e6ed3db856e12bc6017fdf12acd792
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
6 inherit versionator autotools
8 MY_P=${PN}-$(replace_version_separator 3 '~')
10 DESCRIPTION="A light and easy to use libvte based X Terminal Emulator"
11 HOMEPAGE="http://lilyterm.luna.com.tw"
12 SRC_URI="${HOMEPAGE}/file/${MY_P}.tar.gz"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
17 IUSE=""
18 RDEPEND=">=x11-libs/gtk+-2.10
19 >=x11-libs/vte-0.13
20 >=dev-libs/glib-2.14"
21 DEPEND="${RDEPEND}
22 dev-util/pkgconfig
23 dev-util/intltool
24 sys-devel/gettext"
26 S=${WORKDIR}/${MY_P}
27 RESTRICT="mirror"
29 src_prepare() {
30 sed -e '/examplesdir/s/\$(PACKAGE)/&-\${PV}/' \
31 -i data/Makefile.am || die "sed failed"
33 ./autogen.sh || die "autogen.sh failed with exit code $?"
36 src_install() {
37 emake DESTDIR="${D}" install || die "emake install failed."
38 dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"